diff options
author | Samuli Piippo <samuli.piippo@digia.com> | 2014-06-23 10:09:56 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@digia.com> | 2014-06-24 14:53:50 +0300 |
commit | 4918900c5f44676e59641f4947347cedbf9d76cc (patch) | |
tree | a8ad21f198fa65d99b75022117c5ad3971dbfed8 | |
parent | cd55afb6bfd8c4abc29024095179d9599e832841 (diff) | |
download | meta-boot2qt-4918900c5f44676e59641f4947347cedbf9d76cc.tar.gz |
toradex: Add hardware acceleration for gstream
Include FSL gstreamer plugins in Toradex Apalis iMX6 image.
The fls plugins are dependent on imx-lib which are dependent
on the kernel version, so needed to pull older version of imx-lib
recipe from meta-fsl-arm to support the older kernel used by toradex.
Setting preferred version for the latest imx-lib for all other imx6 devices.
Change-Id: I0351c6b1707f2965f756d0298948f29ae1c828f6
Reviewed-by: Kalle Viironen <kalle.viironen@digia.com>
-rw-r--r-- | conf/distro/include/apalis-imx6.conf | 2 | ||||
-rw-r--r-- | conf/distro/include/imx6qsabresd.conf | 1 | ||||
-rw-r--r-- | conf/distro/include/nitrogen6x.conf | 1 | ||||
-rw-r--r-- | recipes/imx-lib/imx-lib_3.10.9-1.0.0.bb | 10 |
4 files changed, 14 insertions, 0 deletions
diff --git a/conf/distro/include/apalis-imx6.conf b/conf/distro/include/apalis-imx6.conf index 114c8b8..144693d 100644 --- a/conf/distro/include/apalis-imx6.conf +++ b/conf/distro/include/apalis-imx6.conf | |||
@@ -29,11 +29,13 @@ BOOTFS_CONTENT = "\ | |||
29 | BOOTFS_DEPENDS = "u-boot:do_deploy" | 29 | BOOTFS_DEPENDS = "u-boot:do_deploy" |
30 | 30 | ||
31 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.9-1.0.0-hfp" | 31 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.9-1.0.0-hfp" |
32 | PREFERRED_VERSION_imx-lib = "3.10.9-1.0.0" | ||
32 | 33 | ||
33 | MACHINE_EXTRA_INSTALL = "\ | 34 | MACHINE_EXTRA_INSTALL = "\ |
34 | libgal-mx6 \ | 35 | libgal-mx6 \ |
35 | libegl-mx6 \ | 36 | libegl-mx6 \ |
36 | libgles2-mx6 \ | 37 | libgles2-mx6 \ |
38 | gst-fsl-plugin \ | ||
37 | " | 39 | " |
38 | 40 | ||
39 | MACHINE_EXTRA_INSTALL_SDK = " \ | 41 | MACHINE_EXTRA_INSTALL_SDK = " \ |
diff --git a/conf/distro/include/imx6qsabresd.conf b/conf/distro/include/imx6qsabresd.conf index 36d579d..a19f85f 100644 --- a/conf/distro/include/imx6qsabresd.conf +++ b/conf/distro/include/imx6qsabresd.conf | |||
@@ -32,6 +32,7 @@ BOOTFS_CONTENT = "\ | |||
32 | BOOTFS_DEPENDS = "u-boot:do_deploy" | 32 | BOOTFS_DEPENDS = "u-boot:do_deploy" |
33 | 33 | ||
34 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.0-hfp" | 34 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.0-hfp" |
35 | PREFERRED_VERSION_imx-lib = "3.10.17-1.0.0" | ||
35 | 36 | ||
36 | MACHINE_EXTRA_INSTALL = "\ | 37 | MACHINE_EXTRA_INSTALL = "\ |
37 | libgal-mx6 \ | 38 | libgal-mx6 \ |
diff --git a/conf/distro/include/nitrogen6x.conf b/conf/distro/include/nitrogen6x.conf index 8b9838e..9af8417 100644 --- a/conf/distro/include/nitrogen6x.conf +++ b/conf/distro/include/nitrogen6x.conf | |||
@@ -35,6 +35,7 @@ BOOTFS_DEPENDS = "u-boot:do_deploy virtual/kernel:do_deploy u-boot-script-bounda | |||
35 | EXTRA_IMAGEDEPENDS += "u-boot-script-boundary" | 35 | EXTRA_IMAGEDEPENDS += "u-boot-script-boundary" |
36 | 36 | ||
37 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.0-hfp" | 37 | PREFERRED_VERSION_gpu-viv-bin-mx6q = "3.10.17-1.0.0-hfp" |
38 | PREFERRED_VERSION_imx-lib = "3.10.17-1.0.0" | ||
38 | 39 | ||
39 | MACHINE_EXTRA_INSTALL = "\ | 40 | MACHINE_EXTRA_INSTALL = "\ |
40 | libgal-mx6 \ | 41 | libgal-mx6 \ |
diff --git a/recipes/imx-lib/imx-lib_3.10.9-1.0.0.bb b/recipes/imx-lib/imx-lib_3.10.9-1.0.0.bb new file mode 100644 index 0000000..f2a736a --- /dev/null +++ b/recipes/imx-lib/imx-lib_3.10.9-1.0.0.bb | |||
@@ -0,0 +1,10 @@ | |||
1 | # Copyright (C) 2013 Freescale Semiconductor | ||
2 | |||
3 | require recipes-bsp/imx-lib/imx-lib.inc | ||
4 | |||
5 | SRC_URI[md5sum] = "5cc9c8d09c7ba401cdab4a2ecbda89e2" | ||
6 | SRC_URI[sha256sum] = "d1581c2f2956731da0c42e9dc17514a4d00790deeb83defeb5e07d14746190d8" | ||
7 | |||
8 | PE = "1" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "(mx6)" | ||