diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2017-10-31 10:49:02 +0200 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2017-11-08 16:53:33 +0000 |
commit | df17ffab8615d5de8659ec8f285e2a92b28cd671 (patch) | |
tree | e9647a5a5c69dcf0ba5bf5ee913e4859b30bf3db | |
parent | 8d075eea57b66c672aead741d591fb7b71dfb170 (diff) | |
download | meta-boot2qt-df17ffab8615d5de8659ec8f285e2a92b28cd671.tar.gz |
automotive: update revisions
Update all automotive components. Merge changes done in pyro
branch.
Change-Id: I9a084b69ff7399c244098a336f0a3a112859fa17
Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
-rw-r--r-- | recipes-qt/automotive/gammaray_git.bb | 6 | ||||
-rw-r--r-- | recipes-qt/automotive/neptune-ui/neptune.service | 4 | ||||
-rw-r--r-- | recipes-qt/automotive/neptune-ui_git.bb | 14 | ||||
-rw-r--r-- | recipes-qt/automotive/qtapplicationmanager_git.bb | 6 | ||||
-rw-r--r-- | recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch | 29 | ||||
-rw-r--r-- | recipes-qt/automotive/qtivi_git.bb | 5 |
6 files changed, 48 insertions, 16 deletions
diff --git a/recipes-qt/automotive/gammaray_git.bb b/recipes-qt/automotive/gammaray_git.bb index 6317040..1de4c09 100644 --- a/recipes-qt/automotive/gammaray_git.bb +++ b/recipes-qt/automotive/gammaray_git.bb | |||
@@ -8,11 +8,11 @@ inherit cmake_qt5 | |||
8 | 8 | ||
9 | SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" | 9 | SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}" |
10 | 10 | ||
11 | BRANCH = "2.7" | 11 | BRANCH = "5.9" |
12 | SRCREV = "a22da6d63cab08f3ef8588611fdbda3f96731efe" | 12 | SRCREV = "ff53d7328d6db17dcb6486bb98b02a2f107b4066" |
13 | PV = "${BRANCH}+git${SRCPV}" | 13 | PV = "${BRANCH}+git${SRCPV}" |
14 | 14 | ||
15 | DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml \ | 15 | DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \ |
16 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" | 16 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" |
17 | 17 | ||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
diff --git a/recipes-qt/automotive/neptune-ui/neptune.service b/recipes-qt/automotive/neptune-ui/neptune.service index 7793d0b..ef73324 100644 --- a/recipes-qt/automotive/neptune-ui/neptune.service +++ b/recipes-qt/automotive/neptune-ui/neptune.service | |||
@@ -3,9 +3,9 @@ Description=Neptune | |||
3 | After=dbus.service dbus-session.service systemd-user-sessions.service | 3 | After=dbus.service dbus-session.service systemd-user-sessions.service |
4 | 4 | ||
5 | [Service] | 5 | [Service] |
6 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml Main.qml | 6 | ExecStart=/usr/bin/appcontroller /usr/bin/appman -r --dbus session -c am-config.yaml |
7 | Restart=on-failure | 7 | Restart=on-failure |
8 | WorkingDirectory=/opt/neptune | 8 | WorkingDirectory=/opt/neptune-ui |
9 | 9 | ||
10 | [Install] | 10 | [Install] |
11 | WantedBy=multi-user.target | 11 | WantedBy=multi-user.target |
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb index b7ca95d..e8d01f2 100644 --- a/recipes-qt/automotive/neptune-ui_git.bb +++ b/recipes-qt/automotive/neptune-ui_git.bb | |||
@@ -29,7 +29,7 @@ | |||
29 | 29 | ||
30 | DESCRIPTION = "Neptune IVI UI" | 30 | DESCRIPTION = "Neptune IVI UI" |
31 | LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" | 31 | LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1" |
32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c" | 32 | LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=c41b4a3e669de55dfe304b8376b04a82" |
33 | 33 | ||
34 | inherit qt5-module systemd | 34 | inherit qt5-module systemd |
35 | require recipes-qt/qt5/qt5-git.inc | 35 | require recipes-qt/qt5/qt5-git.inc |
@@ -41,13 +41,15 @@ SRC_URI += " \ | |||
41 | file://neptune.service \ | 41 | file://neptune.service \ |
42 | " | 42 | " |
43 | 43 | ||
44 | SRCREV = "6ddea70fd06d78ca7672f18221b91b3e8990aee8" | 44 | SRCREV = "2a242aa65f267d010d8c10b8c5da5a1e728d0551" |
45 | 45 | ||
46 | DEPENDS = "qtbase qtdeclarative qttools-native" | 46 | DEPENDS = "qtbase qtdeclarative qttools-native qtquickcontrols2 qtapplicationmanager" |
47 | RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard dbus \ | 47 | RDEPENDS_${PN} = "qtivi qtvirtualkeyboard dbus \ |
48 | qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \ | 48 | qtquickcontrols-qmlplugins qtgraphicaleffects-qmlplugins \ |
49 | ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" | 49 | ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}" |
50 | 50 | ||
51 | EXTRA_QMAKEVARS_PRE += "INSTALL_PREFIX=/opt" | ||
52 | |||
51 | do_install_append() { | 53 | do_install_append() { |
52 | install -m 0755 -d ${D}${systemd_unitdir}/system | 54 | install -m 0755 -d ${D}${systemd_unitdir}/system |
53 | install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ | 55 | install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/ |
@@ -56,9 +58,9 @@ do_install_append() { | |||
56 | PACKAGES =+ "${PN}-apps" | 58 | PACKAGES =+ "${PN}-apps" |
57 | RRECOMMENDS_${PN} += "${PN}-apps" | 59 | RRECOMMENDS_${PN} += "${PN}-apps" |
58 | 60 | ||
59 | FILES_${PN}-apps += "/opt/neptune/apps" | 61 | FILES_${PN}-apps += "/opt/neptune-ui/apps" |
60 | FILES_${PN} += "\ | 62 | FILES_${PN} += "\ |
61 | /opt/neptune \ | 63 | /opt/neptune-ui \ |
62 | " | 64 | " |
63 | 65 | ||
64 | SYSTEMD_SERVICE_${PN} = "neptune.service" | 66 | SYSTEMD_SERVICE_${PN} = "neptune.service" |
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb index 52ee20e..5b112b5 100644 --- a/recipes-qt/automotive/qtapplicationmanager_git.bb +++ b/recipes-qt/automotive/qtapplicationmanager_git.bb | |||
@@ -34,7 +34,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=43a31c6abffdd61c938811959b3c1b71" | |||
34 | inherit qt5-module | 34 | inherit qt5-module |
35 | require recipes-qt/qt5/qt5-git.inc | 35 | require recipes-qt/qt5/qt5-git.inc |
36 | 36 | ||
37 | SRCREV = "f472ef3662cf0a9bc2bf727c7cef18fd884df5a2" | 37 | SRCREV = "57ff870b0790e1e1feb3421cdfb46dff82878825" |
38 | 38 | ||
39 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ | 39 | DEPENDS = "qtbase qtdeclarative libyaml libarchive \ |
40 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" | 40 | ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" |
@@ -60,8 +60,8 @@ FILES_${PN} += "\ | |||
60 | 60 | ||
61 | BBCLASSEXTEND += "nativesdk" | 61 | BBCLASSEXTEND += "nativesdk" |
62 | 62 | ||
63 | DEPENDS_class-nativesdk = "qtbase nativesdk-glibc-locale" | 63 | DEPENDS_class-nativesdk = "qtbase nativesdk-glibc-locale nativesdk-libarchive" |
64 | DEPENDS_class-nativesdk_remove_mingw32 += "nativesdk-glibc-locale" | 64 | DEPENDS_class-nativesdk_remove_mingw32 += "nativesdk-glibc-locale nativesdk-libarchive" |
65 | 65 | ||
66 | EXTRA_QMAKEVARS_PRE_class-nativesdk += "\ | 66 | EXTRA_QMAKEVARS_PRE_class-nativesdk += "\ |
67 | -config tools-only \ | 67 | -config tools-only \ |
diff --git a/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch b/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch new file mode 100644 index 0000000..9f6c0c0 --- /dev/null +++ b/recipes-qt/automotive/qtivi/0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From b4ed8c9d4a391771cba485bfa685147126260dc2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Thu, 7 Sep 2017 10:24:11 +0300 | ||
4 | Subject: [PATCH] Use QT_HOST_BINS/get for getting correct path | ||
5 | |||
6 | Patch QT_HOST_BINS same way as is done it qtbase for getting | ||
7 | the EffectivePath instead of installation path. | ||
8 | |||
9 | Change-Id: I3e9c04019c432e182dcb5c0898275173f20de1e2 | ||
10 | --- | ||
11 | mkspecs/features/ivigenerator.prf | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/mkspecs/features/ivigenerator.prf b/mkspecs/features/ivigenerator.prf | ||
15 | index 65c497e..7634355 100644 | ||
16 | --- a/mkspecs/features/ivigenerator.prf | ||
17 | +++ b/mkspecs/features/ivigenerator.prf | ||
18 | @@ -31,9 +31,9 @@ QFACE_YAML = $$QFACE_ABS_PWD/$${QFACE_BASE_NAME}.yaml | ||
19 | OTHER_FILES += $$QFACE_FILE | ||
20 | |||
21 | # Detect whether we are using the feature inside the qtivi repository | ||
22 | -VIRTUALENV_PATH = $$[QT_HOST_BINS]/ivigenerator/qtivi_qface_virtualenv | ||
23 | +VIRTUALENV_PATH = $$[QT_HOST_BINS/get]/ivigenerator/qtivi_qface_virtualenv | ||
24 | INTERNAL_VIRTUALENV_PATH = $$QTIVI_BUILD_ROOT/src/tools/ivigenerator/qtivi_qface_virtualenv | ||
25 | -IVI_GENERATOR_PATH = $$[QT_HOST_BINS]/ivigenerator | ||
26 | +IVI_GENERATOR_PATH = $$[QT_HOST_BINS/get]/ivigenerator | ||
27 | QTEST_ENVIRONMENT = $$upper($$(QTEST_ENVIRONMENT)) | ||
28 | |||
29 | # Try to use the internal virtualenv when building qtivi | ||
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb index 0f49d5d..3eb48e5 100644 --- a/recipes-qt/automotive/qtivi_git.bb +++ b/recipes-qt/automotive/qtivi_git.bb | |||
@@ -47,10 +47,11 @@ QT_MODULE_BRANCH_QFACE = "upstream/develop" | |||
47 | 47 | ||
48 | SRC_URI += " \ | 48 | SRC_URI += " \ |
49 | ${QT_GIT}/qtivi-qface.git;name=qface;branch=${QT_MODULE_BRANCH_QFACE};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/qface \ | 49 | ${QT_GIT}/qtivi-qface.git;name=qface;branch=${QT_MODULE_BRANCH_QFACE};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/qface \ |
50 | file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \ | ||
50 | " | 51 | " |
51 | 52 | ||
52 | SRCREV_qtivi = "3205b6e8f57273096ae60d8f6fcdbe597c350393" | 53 | SRCREV_qtivi = "705acb8d595d772778dd4985b762ed6a604473d9" |
53 | SRCREV_qface = "b1d96d85a7c43ac74335b9a1a99a68507047f5bc" | 54 | SRCREV_qface = "295824c8df7f74af8f3d1f368ec15942e6622f22" |
54 | SRCREV = "${SRCREV_qtivi}" | 55 | SRCREV = "${SRCREV_qtivi}" |
55 | SRCREV_FORMAT = "qtivi_qface" | 56 | SRCREV_FORMAT = "qtivi_qface" |
56 | 57 | ||