summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-08-18 15:09:17 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-08-19 05:38:46 +0000
commit3720291ed255ef061aa231414b57848294e1e4f9 (patch)
tree24b16d84e1d5703b6e3484f0b1df8fd19711960e
parent2480300674bbd556246edf4988b08a779637d32e (diff)
downloadmeta-boot2qt-3720291ed255ef061aa231414b57848294e1e4f9.tar.gz
qtivi: export envs for ivigenerator
pip3 is run during install phase, so we need to have the environment variables available also then. Change-Id: I43aa285a5da884a0db4b651fb6a0eeb832daef51 Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com>
-rw-r--r--recipes-qt/automotive/qtivi_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index 6b364d3..0f49d5d 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -68,7 +68,7 @@ PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}"
68 68
69EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}" 69EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}"
70 70
71do_compile_prepend() { 71set_python_paths() {
72 # Otherwise pip might cache or reuse something from our home folder 72 # Otherwise pip might cache or reuse something from our home folder
73 export HOME="${STAGING_DATADIR_NATIVE}" 73 export HOME="${STAGING_DATADIR_NATIVE}"
74 # This is needed as otherwise the virtualenv tries to use the libs from the host 74 # This is needed as otherwise the virtualenv tries to use the libs from the host
@@ -76,6 +76,13 @@ do_compile_prepend() {
76 # Let qtivi use the python3-native binaries 76 # Let qtivi use the python3-native binaries
77 export PYTHON3_PATH="${STAGING_BINDIR_NATIVE}/python3-native" 77 export PYTHON3_PATH="${STAGING_BINDIR_NATIVE}/python3-native"
78} 78}
79do_compile_prepend() {
80 set_python_paths
81}
82do_install_prepend() {
83 set_python_paths
84}
85
79 86
80BBCLASSEXTEND += "native nativesdk" 87BBCLASSEXTEND += "native nativesdk"
81 88