diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-09-05 13:34:42 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-09-07 10:40:52 +0000 |
commit | 29b65f9918d27aa05d30c7321f8e3a14b50422c4 (patch) | |
tree | 5f3f7bee51611e2a465e2e750819db844154c5e5 | |
parent | bb2f6ef6d524a0111fd50abb90d86060e30d2102 (diff) | |
download | meta-boot2qt-29b65f9918d27aa05d30c7321f8e3a14b50422c4.tar.gz |
qt5: Enable Link Time Optimization
Re-enable building qtbase and rest of the modules with Link Time Optimization
that significantly improves performance and reduces binary sizes. Exclude it
from QtWebEngine, as it produces unstable binaries for ARM.
Task-number: QTBUG-68688
Change-Id: Ic2448229b878c5b16febf4773dba6c52f5983fd5
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r-- | meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend | 1 | ||||
-rw-r--r-- | meta-boot2qt-distro/recipes-qt/qt5/qtwebengine_git.bbappend | 31 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend index aac5d20..f24556e 100644 --- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend +++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend | |||
@@ -44,6 +44,7 @@ PACKAGECONFIG += " \ | |||
44 | icu \ | 44 | icu \ |
45 | libinput \ | 45 | libinput \ |
46 | linuxfb \ | 46 | linuxfb \ |
47 | ltcg \ | ||
47 | sql-sqlite \ | 48 | sql-sqlite \ |
48 | tslib \ | 49 | tslib \ |
49 | xkbcommon-evdev \ | 50 | xkbcommon-evdev \ |
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtwebengine_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtwebengine_git.bbappend new file mode 100644 index 0000000..cfd3a39 --- /dev/null +++ b/meta-boot2qt-distro/recipes-qt/qt5/qtwebengine_git.bbappend | |||
@@ -0,0 +1,31 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2018 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | # QTBUG-70348 | ||
31 | EXTRA_QMAKEVARS_PRE_append_arm = " CONFIG-=ltcg" | ||