From 23363c990c3d1a485fa6f3c7a77ccc58bf325d1d Mon Sep 17 00:00:00 2001
From: Nitin A Kamble <nitin.a.kamble@intel.com>
Date: Tue, 13 Jul 2010 09:41:25 -0700
Subject: insane.class: print the recipe name in the warning.

Now Warning includes the package name like zlib is printed bellow:

WARNING: zlib: Recipe file does not have license file information
(LIC_FILES_CHKSUM)

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
---
 meta/classes/insane.bbclass | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

(limited to 'meta/classes/insane.bbclass')

diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index 6b14f90027..b7ab98d34f 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -343,11 +343,12 @@ def package_qa_check_license(workdir, d):
     sane = True
 
     lic_files = bb.data.getVar('LIC_FILES_CHKSUM', d, True)
+    pn = bb.data.getVar('PN', d, True)
 
     if not lic_files:
         # just throw a warning now. Once licensing data in entered for enough of the recipes,
         # this will be converted into error and False will be returned.
-        bb.warn(" Recipe (.bb) file does not have license file information (LIC_FILES_CHKSUM)")
+        bb.warn(pn + ": Recipe file does not have license file information (LIC_FILES_CHKSUM)")
         return True
 
     srcdir = bb.data.getVar('S', d, True)
-- 
cgit v1.2.3-54-g00ecf