summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/x86_64/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/x86_64/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/x86_64/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend41
1 files changed, 41 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/x86_64/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend b/scripts/lib/bsp/substrate/target/arch/x86_64/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend
new file mode 100644
index 0000000000..bf5959cc8a
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/x86_64/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.4": }} linux-yocto_3.4.bbappend
@@ -0,0 +1,41 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3PR := "${PR}.1"
4
5COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
6
7{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
8
9{{ if need_new_kbranch == "y": }}
10{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard:standard/common-pc-64" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/common-pc-64/base" }}
11
12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard:standard/common-pc-64" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/common-pc-64/base" }}
14
15{{ if need_new_kbranch == "y": }}
16KBRANCH_{{=machine}} = "{{=strip_base(new_kbranch)}}/{{=machine}}"
17{{ if need_new_kbranch == "n": }}
18KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
19
20KMACHINE_{{=machine}} = "{{=machine}}"
21
22{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
23{{ if smp == "y": }}
24KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
25
26{{ if need_new_kbranch == "y": }}
27YOCTO_KERNEL_EXTERNAL_BRANCH_{{=machine}} = "{{=strip_base(new_kbranch)}}/{{=machine}}"
28{{ if need_new_kbranch == "n": }}
29YOCTO_KERNEL_EXTERNAL_BRANCH_{{=machine}} = "{{=existing_kbranch}}"
30
31SRC_URI += "file://{{=machine}}-standard.scc \
32 file://{{=machine}}.scc \
33 file://{{=machine}}.cfg \
34 file://user-config.cfg \
35 file://user-patches.scc \
36 "
37
38# uncomment and replace these SRCREVs with the real commit ids once you've had
39# the appropriate changes committed to the upstream linux-yocto repo
40#SRCREV_machine_pn-linux-yocto_{{=machine}} ?= "19f7e43b54aef08d58135ed2a897d77b624b320a"
41#SRCREV_meta_pn-linux-yocto_{{=machine}} ?= "459165c1dd61c4e843c36e6a1abeb30949a20ba7"