summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.17": }} linux-yocto_3.17.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.17": }} linux-yocto_3.17.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.17": }} linux-yocto_3.17.bbappend10
1 files changed, 8 insertions, 2 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.17": }} linux-yocto_3.17.bbappend b/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.17": }} linux-yocto_3.17.bbappend
index 2d908ccb6a..ea5eb2cfb1 100644
--- a/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.17": }} linux-yocto_3.17.bbappend
+++ b/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.17": }} linux-yocto_3.17.bbappend
@@ -29,11 +29,17 @@ COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
29{{ if need_new_kbranch == "n" and qemuarch == "x86_64": }} 29{{ if need_new_kbranch == "n" and qemuarch == "x86_64": }}
30{{ input type:"choicelist" name:"existing_kbranch" nameappend:"x86_64" gen:"bsp.kernel.all_branches" branches_base:"standard:standard/common-pc-64" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/common-pc-64/base" }} 30{{ input type:"choicelist" name:"existing_kbranch" nameappend:"x86_64" gen:"bsp.kernel.all_branches" branches_base:"standard:standard/common-pc-64" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/common-pc-64/base" }}
31 31
32{{ if need_new_kbranch == "n" and qemuarch == "mips": }}
33{{ input type:"choicelist" name:"existing_kbranch" nameappend:"mips" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/mti-malta32" }}
34
35{{ if need_new_kbranch == "n" and qemuarch == "mips64": }}
36{{ input type:"choicelist" name:"existing_kbranch" nameappend:"mips64" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/mti-malta64" }}
37
32{{ if need_new_kbranch == "y" and qemuarch == "mips": }} 38{{ if need_new_kbranch == "y" and qemuarch == "mips": }}
33{{ input type:"choicelist" name:"new_kbranch" nameappend:"mips" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }} 39{{ input type:"choicelist" name:"new_kbranch" nameappend:"mips" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
34 40
35{{ if need_new_kbranch == "n" and qemuarch == "mips": }} 41{{ if need_new_kbranch == "y" and qemuarch == "mips64": }}
36{{ input type:"choicelist" name:"existing_kbranch" nameappend:"mips" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/mti-malta32" }} 42{{ input type:"choicelist" name:"new_kbranch" nameappend:"mips64" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
37 43
38{{ if need_new_kbranch == "n": }} 44{{ if need_new_kbranch == "n": }}
39KBRANCH_{{=machine}} = "{{=existing_kbranch}}" 45KBRANCH_{{=machine}} = "{{=existing_kbranch}}"