summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.0": }} linux-yocto-rt_3.0.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.0": }} linux-yocto-rt_3.0.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.0": }} linux-yocto-rt_3.0.bbappend61
1 files changed, 61 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.0": }} linux-yocto-rt_3.0.bbappend b/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.0": }} linux-yocto-rt_3.0.bbappend
new file mode 100644
index 0000000000..21e52343a6
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/qemu/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.0": }} linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,61 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3PR := "${PR}.1"
4
5COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
6
7{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
8
9{{ if need_new_kbranch == "y" and qemuarch == "arm": }}
10{{ input type:"choicelist" name:"new_kbranch" nameappend:"arm" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt" }}
11
12{{ if need_new_kbranch == "n" and qemuarch == "arm": }}
13{{ input type:"choicelist" name:"existing_kbranch" nameappend:"arm" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt/base" }}
14
15{{ if need_new_kbranch == "y" and qemuarch == "powerpc": }}
16{{ input type:"choicelist" name:"new_kbranch" nameappend:"powerpc" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt" }}
17
18{{ if need_new_kbranch == "n" and qemuarch == "powerpc": }}
19{{ input type:"choicelist" name:"existing_kbranch" nameappend:"powerpc" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt/qemu-ppc32" }}
20
21{{ if need_new_kbranch == "y" and qemuarch == "i386": }}
22{{ input type:"choicelist" name:"new_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt" }}
23
24{{ if need_new_kbranch == "n" and qemuarch == "i386": }}
25{{ input type:"choicelist" name:"existing_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt/base" }}
26
27{{ if need_new_kbranch == "y" and qemuarch == "x86_64": }}
28{{ input type:"choicelist" name:"new_kbranch" nameappend:"x86_64" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt" }}
29
30{{ if need_new_kbranch == "n" and qemuarch == "x86_64": }}
31{{ input type:"choicelist" name:"existing_kbranch" nameappend:"x86_64" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt/base" }}
32
33{{ if need_new_kbranch == "y" and qemuarch == "mips": }}
34{{ input type:"choicelist" name:"new_kbranch" nameappend:"mips" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt" }}
35
36{{ if need_new_kbranch == "n" and qemuarch == "mips": }}
37{{ input type:"choicelist" name:"existing_kbranch" nameappend:"mips" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"yocto/standard/preempt-rt/base" }}
38
39{{ if need_new_kbranch == "y": }}
40KBRANCH_{{=machine}} = "{{=new_kbranch}}/{{=machine}}"
41{{ if need_new_kbranch == "n": }}
42KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
43
44{{ if need_new_kbranch == "y": }}
45YOCTO_KERNEL_EXTERNAL_BRANCH_{{=machine}} = "{{=new_kbranch}}/{{=machine}}"
46
47KMACHINE_{{=machine}} = "{{=machine}}"
48
49{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
50{{ if smp == "y": }}
51KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
52
53SRC_URI += "file://{{=machine}}-preempt-rt.scc \
54 file://{{=machine}}.scc \
55 file://{{=machine}}.cfg \
56 "
57
58# uncomment and replace these SRCREVs with the real commit ids once you've had
59# the appropriate changes committed to the upstream linux-yocto repo
60#SRCREV_machine_pn-linux-yocto-rt_{{=machine}} ?= "417fc778a86e81303bab5883b919ee422ec51c04"
61#SRCREV_meta_pn-linux-yocto-rt_{{=machine}} ?= "138bf5b502607fe40315c0d76822318d77d97e01"