summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend37
1 files changed, 0 insertions, 37 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend b/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
deleted file mode 100644
index 9172aa5992..0000000000
--- a/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
+++ /dev/null
@@ -1,37 +0,0 @@
1# yocto-bsp-filename {{ if kernel_choice == "linux-yocto-tiny_4.1": }} this
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4PR := "${PR}.1"
5
6COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
7
8{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
9
10{{ if need_new_kbranch == "y": }}
11{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
12
13{{ if need_new_kbranch == "n": }}
14{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
15
16{{ if need_new_kbranch == "n": }}
17KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
18
19{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
20{{ if smp == "y": }}
21KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
22
23SRC_URI += "file://{{=machine}}.scc \
24 file://{{=machine}}.cfg \
25 file://{{=machine}}-tiny.scc \
26 file://{{=machine}}-user-config.cfg \
27 file://{{=machine}}-user-patches.scc \
28 file://{{=machine}}-user-features.scc \
29 "
30
31# replace these SRCREVs with the real commit ids once you've had
32# the appropriate changes committed to the upstream linux-yocto repo
33SRCREV_machine_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}"
34SRCREV_meta_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}"
35#LINUX_VERSION = "4.1"
36#Remove the following line once AUTOREV is locked to a certain SRCREV
37KERNEL_VERSION_SANITY_SKIP = "1"