summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/layer/recipes-example/example/example-recipe-0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/layer/recipes-example/example/example-recipe-0.1.bb')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/layer/recipes-example/example/example-recipe-0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/layer/recipes-example/example/example-recipe-0.1.bb b/scripts/lib/bsp/substrate/target/arch/layer/recipes-example/example/example-recipe-0.1.bb
new file mode 100644
index 0000000000..ba1ccb16c6
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/layer/recipes-example/example/example-recipe-0.1.bb
@@ -0,0 +1,24 @@
1# yocto-bsp-filename {{=example_recipe_name}}_0.1.bb
2#
3# This file was derived from the 'Hello World!' example recipe in the
4# Yocto Project Development Manual.
5#
6
7DESCRIPTION = "Simple helloworld application"
8SECTION = "examples"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
11PR = "r0"
12
13SRC_URI = "file://helloworld.c"
14
15S = "${WORKDIR}"
16
17do_compile() {
18 ${CC} helloworld.c -o helloworld
19}
20
21do_install() {
22 install -d ${D}${bindir}
23 install -m 0755 helloworld ${D}${bindir}
24}