summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/layer/{{ if create_example_recipe == "y": }} recipes-example/example/{{=example_recipe_name}}_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/layer/{{ if create_example_recipe == "y": }} recipes-example/example/{{=example_recipe_name}}_0.1.bb')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/layer/{{ if create_example_recipe == "y": }} recipes-example/example/{{=example_recipe_name}}_0.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/layer/{{ if create_example_recipe == "y": }} recipes-example/example/{{=example_recipe_name}}_0.1.bb b/scripts/lib/bsp/substrate/target/arch/layer/{{ if create_example_recipe == "y": }} recipes-example/example/{{=example_recipe_name}}_0.1.bb
new file mode 100644
index 0000000000..14bf344da5
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/layer/{{ if create_example_recipe == "y": }} recipes-example/example/{{=example_recipe_name}}_0.1.bb
@@ -0,0 +1,23 @@
1#
2# This file was derived from the 'Hello World!' example recipe in the
3# Yocto Project Development Manual.
4#
5
6DESCRIPTION = "Simple helloworld application"
7SECTION = "examples"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
10PR = "r0"
11
12SRC_URI = "file://helloworld.c"
13
14S = "${WORKDIR}"
15
16do_compile() {
17 ${CC} helloworld.c -o helloworld
18}
19
20do_install() {
21 install -d ${D}${bindir}
22 install -m 0755 helloworld ${D}${bindir}
23}