summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend15
1 files changed, 3 insertions, 12 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend b/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend
index 1ae5ceee18..088bcc2d4c 100644
--- a/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend
+++ b/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.4": }} linux-yocto-rt_3.4.bbappend
@@ -12,26 +12,17 @@ COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
12{{ if need_new_kbranch == "n": }} 12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/preempt-rt" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/preempt-rt/base" }} 13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/preempt-rt" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/preempt-rt/base" }}
14 14
15{{ if need_new_kbranch == "y": }}
16KBRANCH_DEFAULT_{{=machine}} = "{{=strip_base(new_kbranch)}}/{{=machine}}"
17KBRANCH_{{=machine}} = "${KBRANCH_DEFAULT}"
18{{ if need_new_kbranch == "n": }}
19KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
20
21KMACHINE_{{=machine}} = "{{=machine}}"
22
23{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}} 15{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
24{{ if smp == "y": }} 16{{ if smp == "y": }}
25KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc" 17KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
26 18
27SRC_URI += "file://{{=machine}}-preempt-rt.scc \ 19SRC_URI += "file://{{=machine}}-preempt-rt.scc \
28 file://{{=machine}}.scc \
29 file://{{=machine}}.cfg \
30 file://{{=machine}}-user-config.cfg \ 20 file://{{=machine}}-user-config.cfg \
31 file://{{=machine}}-user-patches.scc \ 21 file://{{=machine}}-user-patches.scc \
32 " 22 "
33 23
34# uncomment and replace these SRCREVs with the real commit ids once you've had 24# uncomment and replace these SRCREVs with the real commit ids once you've had
35# the appropriate changes committed to the upstream linux-yocto repo 25# the appropriate changes committed to the upstream linux-yocto repo
36#SRCREV_machine_pn-linux-yocto-rt_{{=machine}} ?= "2d008a6dcbf565878cee14c5f050eca53897316f" 26#SRCREV_machine_pn-linux-yocto-rt_{{=machine}} ?= "c3fa9782d3c6caabbca85d56fc4ace0ba97b9d9e"
37#SRCREV_meta_pn-linux-yocto-rt_{{=machine}} ?= "459165c1dd61c4e843c36e6a1abeb30949a20ba7a" 27#SRCREV_meta_pn-linux-yocto-rt_{{=machine}} ?= "4fd76cc4f33e0afd8f906b1e8f231b6d13b6c993"
28#LINUX_VERSION = "3.4.34"