summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/linux-yocto-custom.bb
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/linux-yocto-custom.bb')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/linux-yocto-custom.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/linux-yocto-custom.bb b/scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/linux-yocto-custom.bb
new file mode 100644
index 0000000000..80a52e7cae
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/linux-yocto-custom.bb
@@ -0,0 +1,58 @@
1# yocto-bsp-filename {{ if kernel_choice == "custom": }} this
2# This file was derived from the linux-yocto-custom.bb recipe in
3# oe-core.
4#
5# linux-yocto-custom.bb:
6#
7# A yocto-bsp-generated kernel recipe that uses the linux-yocto and
8# oe-core kernel classes to apply a subset of yocto kernel
9# management to git managed kernel repositories.
10#
11# Warning:
12#
13# Building this kernel without providing a defconfig or BSP
14# configuration will result in build or boot errors. This is not a
15# bug.
16#
17# Notes:
18#
19# patches: patches can be merged into to the source git tree itself,
20# added via the SRC_URI, or controlled via a BSP
21# configuration.
22#
23# example configuration addition:
24# SRC_URI += "file://smp.cfg"
25# example patch addition:
26# SRC_URI += "file://0001-linux-version-tweak.patch
27# example feature addition:
28# SRC_URI += "file://feature.scc"
29#
30
31inherit kernel
32require recipes-kernel/linux/linux-yocto.inc
33
34{{ if kernel_choice == "custom" and custom_kernel_remote == "y": }}
35SRC_URI = "{{=custom_kernel_remote_path}};protocol=git;bareclone=1;branch=${KBRANCH}"
36{{ if kernel_choice == "custom" and custom_kernel_remote == "n": }}
37SRC_URI = "git://{{=custom_kernel_local_path}};protocol=file;bareclone=1;branch=${KBRANCH}"
38
39SRC_URI += "file://defconfig"
40
41SRC_URI += "file://{{=machine}}.scc \
42 file://{{=machine}}.cfg \
43 file://{{=machine}}-user-config.cfg \
44 file://{{=machine}}-user-patches.scc \
45 "
46
47{{ if kernel_choice == "custom" and custom_kernel_need_kbranch == "y" and custom_kernel_kbranch and custom_kernel_kbranch != "master": }}
48KBRANCH = "{{=custom_kernel_kbranch}}"
49
50LINUX_VERSION ?= "{{=custom_kernel_linux_version}}"
51LINUX_VERSION_EXTENSION ?= "{{=custom_kernel_linux_version_extension}}"
52
53SRCREV="{{=custom_kernel_srcrev}}"
54
55PR = "r0"
56PV = "${LINUX_VERSION}+git${SRCPV}"
57
58COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"