summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/{{ if kernel_choice == "custom": }} linux-yocto-custom.bb
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/{{ if kernel_choice == "custom": }} linux-yocto-custom.bb')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/{{ if kernel_choice == "custom": }} linux-yocto-custom.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/{{ if kernel_choice == "custom": }} linux-yocto-custom.bb b/scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/{{ if kernel_choice == "custom": }} linux-yocto-custom.bb
new file mode 100644
index 0000000000..5471c93227
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/common/recipes-kernel/linux/{{ if kernel_choice == "custom": }} linux-yocto-custom.bb
@@ -0,0 +1,57 @@
1# This file was derived from the linux-yocto-custom.bb recipe in
2# oe-core.
3#
4# linux-yocto-custom.bb:
5#
6# A yocto-bsp-generated kernel recipe that uses the linux-yocto and
7# oe-core kernel classes to apply a subset of yocto kernel
8# management to git managed kernel repositories.
9#
10# Warning:
11#
12# Building this kernel without providing a defconfig or BSP
13# configuration will result in build or boot errors. This is not a
14# bug.
15#
16# Notes:
17#
18# patches: patches can be merged into to the source git tree itself,
19# added via the SRC_URI, or controlled via a BSP
20# configuration.
21#
22# example configuration addition:
23# SRC_URI += "file://smp.cfg"
24# example patch addition:
25# SRC_URI += "file://0001-linux-version-tweak.patch
26# example feature addition:
27# SRC_URI += "file://feature.scc"
28#
29
30inherit kernel
31require recipes-kernel/linux/linux-yocto.inc
32
33{{ if kernel_choice == "custom" and custom_kernel_remote == "y": }}
34SRC_URI = "{{=custom_kernel_remote_path}};protocol=git;bareclone=1"
35{{ if kernel_choice == "custom" and custom_kernel_remote == "n": }}
36SRC_URI = "git://{{=custom_kernel_local_path}};protocol=file;bareclone=1"
37
38SRC_URI += "file://defconfig"
39
40SRC_URI += "file://{{=machine}}.scc \
41 file://{{=machine}}.cfg \
42 file://user-config.cfg \
43 file://user-patches.scc \
44 "
45
46{{ if kernel_choice == "custom" and custom_kernel_need_kbranch == "y" and custom_kernel_kbranch and custom_kernel_kbranch != "master": }}
47KBRANCH = "{{=custom_kernel_kbranch}}"
48
49LINUX_VERSION ?= "{{=custom_kernel_linux_version}}"
50LINUX_VERSION_EXTENSION ?= "{{=custom_kernel_linux_version_extension}}"
51
52SRCREV="{{=custom_kernel_srcrev}}"
53
54PR = "r0"
55PV = "${LINUX_VERSION}+git${SRCPV}"
56
57COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"