summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.2": }} linux-yocto_3.2.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.2": }} linux-yocto_3.2.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.2": }} linux-yocto_3.2.bbappend39
1 files changed, 39 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.2": }} linux-yocto_3.2.bbappend b/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.2": }} linux-yocto_3.2.bbappend
new file mode 100644
index 0000000000..5480e90b26
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.2": }} linux-yocto_3.2.bbappend
@@ -0,0 +1,39 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3PR := "${PR}.1"
4
5COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
6
7{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
8
9{{ if need_new_kbranch == "y": }}
10{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/default" }}
11
12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/default" }}
14
15{{ if need_new_kbranch == "y": }}
16KBRANCH_{{=machine}} = "{{=new_kbranch}}/{{=machine}}"
17{{ if need_new_kbranch == "n": }}
18KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
19
20{{ if need_new_kbranch == "y": }}
21YOCTO_KERNEL_EXTERNAL_BRANCH_{{=machine}} = "{{=new_kbranch}}/{{=machine}}"
22
23KMACHINE_{{=machine}} = "{{=machine}}"
24
25{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
26{{ if smp == "y": }}
27KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
28
29SRC_URI += "file://{{=machine}}-standard.scc \
30 file://{{=machine}}.scc \
31 file://{{=machine}}.cfg \
32 file://user-config.cfg \
33 file://user-patches.scc \
34 "
35
36# uncomment and replace these SRCREVs with the real commit ids once you've had
37# the appropriate changes committed to the upstream linux-yocto repo
38#SRCREV_machine_pn-linux-yocto_{{=machine}} ?= "417fc778a86e81303bab5883b919ee422ec51c04"
39#SRCREV_meta_pn-linux-yocto_{{=machine}} ?= "138bf5b502607fe40315c0d76822318d77d97e01"