summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.2": }} linux-yocto-rt_3.2.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.2": }} linux-yocto-rt_3.2.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.2": }} linux-yocto-rt_3.2.bbappend37
1 files changed, 0 insertions, 37 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.2": }} linux-yocto-rt_3.2.bbappend b/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.2": }} linux-yocto-rt_3.2.bbappend
deleted file mode 100644
index c2c047c300..0000000000
--- a/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.2": }} linux-yocto-rt_3.2.bbappend
+++ /dev/null
@@ -1,37 +0,0 @@
1FILESEXTRAPATHS_prepend_{{=machine}} := "${THISDIR}/files:"
2
3PR := "${PR}.1"
4
5COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
6
7{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
8
9{{ if need_new_kbranch == "y": }}
10{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/preempt-rt" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/preempt-rt/base" }}
11
12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/preempt-rt" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/preempt-rt/base" }}
14
15{{ if need_new_kbranch == "y": }}
16KBRANCH_DEFAULT_{{=machine}} = "{{=strip_base(new_kbranch)}}/{{=machine}}"
17KBRANCH_{{=machine}} = "${KBRANCH_DEFAULT}"
18{{ if need_new_kbranch == "n": }}
19KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
20
21KMACHINE_{{=machine}} = "{{=machine}}"
22
23{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
24{{ if smp == "y": }}
25KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
26
27SRC_URI += "file://{{=machine}}-preempt-rt.scc \
28 file://{{=machine}}.scc \
29 file://{{=machine}}.cfg \
30 file://{{=machine}}-user-config.cfg \
31 file://{{=machine}}-user-patches.scc \
32 "
33
34# uncomment and replace these SRCREVs with the real commit ids once you've had
35# the appropriate changes committed to the upstream linux-yocto repo
36#SRCREV_machine_pn-linux-yocto-rt_{{=machine}} ?= "01c5c310886e87e785db5c3bb776deb5ed2e03b2"
37#SRCREV_meta_pn-linux-yocto-rt_{{=machine}} ?= "486f7aec824b4127e91ef53228823e996b3696f0"