summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/udev/udev-071/flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/udev/udev-071/flags.patch')
-rw-r--r--openembedded/packages/udev/udev-071/flags.patch72
1 files changed, 0 insertions, 72 deletions
diff --git a/openembedded/packages/udev/udev-071/flags.patch b/openembedded/packages/udev/udev-071/flags.patch
deleted file mode 100644
index cb17336212..0000000000
--- a/openembedded/packages/udev/udev-071/flags.patch
+++ /dev/null
@@ -1,72 +0,0 @@
1Index: udev-071/Makefile
2===================================================================
3--- udev-071.orig/Makefile 2005-10-19 23:28:34.000000000 +0100
4+++ udev-071/Makefile 2005-11-01 22:04:31.000000000 +0000
5@@ -160,36 +160,36 @@
6 # check if compiler option is supported
7 cc-supports = ${shell if $(CC) ${1} -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi;}
8
9-CFLAGS += -Wall -fno-builtin -Wchar-subscripts -Wpointer-arith \
10+override CFLAGS += -Wall -fno-builtin -Wchar-subscripts -Wpointer-arith \
11 -Wstrict-prototypes -Wsign-compare
12-CFLAGS += $(call cc-supports, -Wdeclaration-after-statement, )
13-CFLAGS += -pipe
14-CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
15+override CFLAGS += $(call cc-supports, -Wdeclaration-after-statement, )
16+override CFLAGS += -pipe
17+override CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
18
19 # use '-Os' optimization if available, else use -O2
20 OPTFLAGS := $(call cc-supports, -Os, -O2)
21
22 # include our local copy of libsysfs
23-CFLAGS += -I$(PWD)/libsysfs/sysfs \
24+override CFLAGS += -I$(PWD)/libsysfs/sysfs \
25 -I$(PWD)/libsysfs
26
27 ifeq ($(strip $(USE_LOG)),true)
28- CFLAGS += -DUSE_LOG
29+ override CFLAGS += -DUSE_LOG
30 endif
31
32 # if DEBUG is enabled, then we do not strip or optimize
33 ifeq ($(strip $(DEBUG)),true)
34- CFLAGS += -O1 -g -DDEBUG
35+ override CFLAGS += -O1 -g -DDEBUG
36 LDFLAGS += -Wl
37 STRIPCMD = /bin/true -Since_we_are_debugging
38 else
39- CFLAGS += $(OPTFLAGS) -fomit-frame-pointer
40+ override CFLAGS += $(OPTFLAGS) -fomit-frame-pointer
41 LDFLAGS += -s -Wl
42 STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
43 endif
44
45 ifeq ($(strip $(USE_GCOV)),true)
46- CFLAGS += -fprofile-arcs -ftest-coverage
47+ override CFLAGS += -fprofile-arcs -ftest-coverage
48 LDFLAGS = -fprofile-arcs
49 endif
50
51@@ -200,18 +200,18 @@
52 CC = $(KLCC)
53 LD = $(KLCC)
54 else
55- CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
56+ override CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
57 LDFLAGS += -Wl,-warn-common
58 endif
59
60 ifeq ($(strip $(USE_SELINUX)),true)
61 UDEV_OBJS += udev_selinux.o
62 LIB_OBJS += -lselinux -lsepol
63- CFLAGS += -DUSE_SELINUX
64+ override CFLAGS += -DUSE_SELINUX
65 endif
66
67 ifeq ($(strip $(USE_STATIC)),true)
68- CFLAGS += -DUSE_STATIC
69+ override CFLAGS += -DUSE_STATIC
70 LDFLAGS += -static
71 endif
72