diff options
Diffstat (limited to 'openembedded/packages/module-init-tools')
-rw-r--r-- | openembedded/packages/module-init-tools/files/ignore_arch_directory | 21 | ||||
-rw-r--r-- | openembedded/packages/module-init-tools/files/manpagesopt | 22 | ||||
-rw-r--r-- | openembedded/packages/module-init-tools/module-init-tools-3.2.1/ignore_arch_directory | 24 | ||||
-rw-r--r-- | openembedded/packages/module-init-tools/module-init-tools-3.2.1/manpagesopt | 41 | ||||
-rw-r--r-- | openembedded/packages/module-init-tools/module-init-tools-cross_3.1.bb | 24 | ||||
-rw-r--r-- | openembedded/packages/module-init-tools/module-init-tools-cross_3.2.2.bb | 15 | ||||
-rw-r--r-- | openembedded/packages/module-init-tools/module-init-tools_3.1.bb | 60 | ||||
-rw-r--r-- | openembedded/packages/module-init-tools/module-init-tools_3.2.2.bb (renamed from openembedded/packages/module-init-tools/module-init-tools_3.2.1.bb) | 0 |
8 files changed, 37 insertions, 170 deletions
diff --git a/openembedded/packages/module-init-tools/files/ignore_arch_directory b/openembedded/packages/module-init-tools/files/ignore_arch_directory index 2c71043221..185ea7a3a5 100644 --- a/openembedded/packages/module-init-tools/files/ignore_arch_directory +++ b/openembedded/packages/module-init-tools/files/ignore_arch_directory | |||
@@ -1,25 +1,24 @@ | |||
1 | diff -ruN module-init-tools-3.1-pre6.orig/modprobe.8 module-init-tools-3.1-pre6/modprobe.8 | 1 | diff -ruN module-init-tools-3.1-pre6.orig/modprobe.8 module-init-tools-3.1-pre6/modprobe.8 |
2 | --- module-init-tools-3.1-pre6.orig/modprobe.8 2004-10-06 02:44:43.000000000 +0200 | 2 | --- module-init-tools-3.2-pre7/modprobe.8.orig 2005-07-05 13:52:32.000000000 +0200 |
3 | +++ module-init-tools-3.1-pre6/modprobe.8 2004-10-09 01:39:01.000000000 +0200 | 3 | +++ module-init-tools-3.2-pre7/modprobe.8 2005-07-05 13:52:42.000000000 +0200 |
4 | @@ -30,6 +30,7 @@ | 4 | @@ -31,6 +31,7 @@ |
5 | the modules and other files, except for the optional | 5 | \fI/etc/modprobe.conf\fR configuration file and |
6 | \fI/etc/modprobe.conf\fR configuration file | 6 | \fI/etc/modprobe.d\fR directory |
7 | (see \fBmodprobe.conf\fR(5)). | 7 | (see \fBmodprobe.conf\fR(5)). |
8 | +All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored. | 8 | +All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored. |
9 | .PP | 9 | .PP |
10 | Note that this version of \fBmodprobe\fR does not | 10 | Note that this version of \fBmodprobe\fR does not |
11 | do anything to the module itself: the work of resolving symbols | 11 | do anything to the module itself: the work of resolving symbols |
12 | diff -ruN module-init-tools-3.1-pre6.orig/modprobe.c module-init-tools-3.1-pre6/modprobe.c | 12 | --- module-init-tools-3.2-pre7/modprobe.c.orig 2005-07-05 13:50:00.000000000 +0200 |
13 | --- module-init-tools-3.1-pre6.orig/modprobe.c 2004-10-09 01:40:18.000000000 +0200 | 13 | +++ module-init-tools-3.2-pre7/modprobe.c 2005-07-05 13:50:15.000000000 +0200 |
14 | +++ module-init-tools-3.1-pre6/modprobe.c 2004-10-09 01:40:11.000000000 +0200 | 14 | @@ -1158,6 +1158,10 @@ |
15 | @@ -1082,6 +1082,10 @@ | ||
16 | { | ||
17 | DIR *dir; | 15 | DIR *dir; |
16 | int ret = 0; | ||
18 | 17 | ||
19 | + /* ignore everything in this directory */ | 18 | + /* ignore everything in this directory */ |
20 | + if (streq(filename, "/etc/modprobe.d/arch")) | 19 | + if (streq(filename, "/etc/modprobe.d/arch")) |
21 | + return 1; | 20 | + return 1; |
22 | + | 21 | + |
23 | /* If it's a directory, recurse. */ | 22 | /* Reiser4 has file/directory duality: treat it as both. */ |
24 | dir = opendir(filename); | 23 | dir = opendir(filename); |
25 | if (dir) { | 24 | if (dir) { |
diff --git a/openembedded/packages/module-init-tools/files/manpagesopt b/openembedded/packages/module-init-tools/files/manpagesopt index 2e9d228d58..5d5cac609e 100644 --- a/openembedded/packages/module-init-tools/files/manpagesopt +++ b/openembedded/packages/module-init-tools/files/manpagesopt | |||
@@ -1,7 +1,7 @@ | |||
1 | Index: module-init-tools-3.1/configure.in | 1 | Index: module-init-tools-3.2-pre9/configure.in |
2 | =================================================================== | 2 | =================================================================== |
3 | --- module-init-tools-3.1.orig/configure.in 2004-11-12 00:05:25.000000000 -0500 | 3 | --- module-init-tools-3.2-pre9.orig/configure.in 2005-08-09 04:31:26.000000000 +0000 |
4 | +++ module-init-tools-3.1/configure.in 2005-01-20 02:23:16.409792288 -0500 | 4 | +++ module-init-tools-3.2-pre9/configure.in 2005-09-20 22:06:10.000000000 +0000 |
5 | @@ -41,5 +41,14 @@ | 5 | @@ -41,5 +41,14 @@ |
6 | fi]) | 6 | fi]) |
7 | AC_SUBST(MODULE_DIR) | 7 | AC_SUBST(MODULE_DIR) |
@@ -18,22 +18,24 @@ Index: module-init-tools-3.1/configure.in | |||
18 | +AM_CONDITIONAL([MANPAGES], test x"$enable_manpages" = x"yes") | 18 | +AM_CONDITIONAL([MANPAGES], test x"$enable_manpages" = x"yes") |
19 | 19 | ||
20 | +AC_OUTPUT([Makefile]) | 20 | +AC_OUTPUT([Makefile]) |
21 | Index: module-init-tools-3.1/Makefile.am | 21 | Index: module-init-tools-3.2-pre9/Makefile.am |
22 | =================================================================== | 22 | =================================================================== |
23 | --- module-init-tools-3.1.orig/Makefile.am 2004-07-12 02:11:46.000000000 -0400 | 23 | --- module-init-tools-3.2-pre9.orig/Makefile.am 2005-08-09 04:54:28.000000000 +0000 |
24 | +++ module-init-tools-3.1/Makefile.am 2005-01-20 02:24:32.155277224 -0500 | 24 | +++ module-init-tools-3.2-pre9/Makefile.am 2005-09-20 22:09:03.000000000 +0000 |
25 | @@ -21,11 +21,12 @@ | 25 | @@ -21,13 +21,14 @@ |
26 | MAN5 = modprobe.conf.5 modules.dep.5 | 26 | MAN5 = modprobe.conf.5 modules.dep.5 |
27 | MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8 | 27 | MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8 |
28 | SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml)) | 28 | SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml)) |
29 | -man_MANS = $(MAN5) $(MAN8) | 29 | -man_MANS = $(MAN5) $(MAN8) |
30 | mandir = $(shell if [ `echo $(prefix)/ | tr -s /` = / ]; then echo /usr/share/man; else echo $(prefix)/man; fi) | 30 | # If they haven't overridden mandir, fix it (never /man!) |
31 | mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi) | ||
31 | 32 | ||
33 | TESTSUITE := $(shell find tests -type f ! -name '*~') tests/vg-suppressions | ||
34 | |||
35 | -EXTRA_DIST = generate-modprobe.conf modprobe.devfs FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE) | ||
32 | +if MANPAGES | 36 | +if MANPAGES |
33 | +man_MANS = $(MAN5) $(MAN8) | 37 | +man_MANS = $(MAN5) $(MAN8) |
34 | +endif | 38 | +endif |
35 | 39 | ||
36 | -EXTRA_DIST = generate-modprobe.conf modprobe.devfs FAQ stress_modules.sh install-with-care $(SGML) $(man_MANS) | ||
37 | |||
38 | sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo insmod.static | 40 | sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo insmod.static |
39 | bin_PROGRAMS = lsmod | 41 | bin_PROGRAMS = lsmod |
diff --git a/openembedded/packages/module-init-tools/module-init-tools-3.2.1/ignore_arch_directory b/openembedded/packages/module-init-tools/module-init-tools-3.2.1/ignore_arch_directory deleted file mode 100644 index 185ea7a3a5..0000000000 --- a/openembedded/packages/module-init-tools/module-init-tools-3.2.1/ignore_arch_directory +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | diff -ruN module-init-tools-3.1-pre6.orig/modprobe.8 module-init-tools-3.1-pre6/modprobe.8 | ||
2 | --- module-init-tools-3.2-pre7/modprobe.8.orig 2005-07-05 13:52:32.000000000 +0200 | ||
3 | +++ module-init-tools-3.2-pre7/modprobe.8 2005-07-05 13:52:42.000000000 +0200 | ||
4 | @@ -31,6 +31,7 @@ | ||
5 | \fI/etc/modprobe.conf\fR configuration file and | ||
6 | \fI/etc/modprobe.d\fR directory | ||
7 | (see \fBmodprobe.conf\fR(5)). | ||
8 | +All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored. | ||
9 | .PP | ||
10 | Note that this version of \fBmodprobe\fR does not | ||
11 | do anything to the module itself: the work of resolving symbols | ||
12 | --- module-init-tools-3.2-pre7/modprobe.c.orig 2005-07-05 13:50:00.000000000 +0200 | ||
13 | +++ module-init-tools-3.2-pre7/modprobe.c 2005-07-05 13:50:15.000000000 +0200 | ||
14 | @@ -1158,6 +1158,10 @@ | ||
15 | DIR *dir; | ||
16 | int ret = 0; | ||
17 | |||
18 | + /* ignore everything in this directory */ | ||
19 | + if (streq(filename, "/etc/modprobe.d/arch")) | ||
20 | + return 1; | ||
21 | + | ||
22 | /* Reiser4 has file/directory duality: treat it as both. */ | ||
23 | dir = opendir(filename); | ||
24 | if (dir) { | ||
diff --git a/openembedded/packages/module-init-tools/module-init-tools-3.2.1/manpagesopt b/openembedded/packages/module-init-tools/module-init-tools-3.2.1/manpagesopt deleted file mode 100644 index 5d5cac609e..0000000000 --- a/openembedded/packages/module-init-tools/module-init-tools-3.2.1/manpagesopt +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | Index: module-init-tools-3.2-pre9/configure.in | ||
2 | =================================================================== | ||
3 | --- module-init-tools-3.2-pre9.orig/configure.in 2005-08-09 04:31:26.000000000 +0000 | ||
4 | +++ module-init-tools-3.2-pre9/configure.in 2005-09-20 22:06:10.000000000 +0000 | ||
5 | @@ -41,5 +41,14 @@ | ||
6 | fi]) | ||
7 | AC_SUBST(MODULE_DIR) | ||
8 | |||
9 | -AC_OUTPUT([Makefile]) | ||
10 | +AC_ARG_ENABLE(manpages, | ||
11 | +[ --disable-manpages Disable man page generation.], | ||
12 | +[if test x"$enableval" != x"no"; then | ||
13 | + enable_manpages=yes | ||
14 | +else | ||
15 | + enable_manpages=no | ||
16 | +fi], | ||
17 | +[enable_manpages=yes]) | ||
18 | +AM_CONDITIONAL([MANPAGES], test x"$enable_manpages" = x"yes") | ||
19 | |||
20 | +AC_OUTPUT([Makefile]) | ||
21 | Index: module-init-tools-3.2-pre9/Makefile.am | ||
22 | =================================================================== | ||
23 | --- module-init-tools-3.2-pre9.orig/Makefile.am 2005-08-09 04:54:28.000000000 +0000 | ||
24 | +++ module-init-tools-3.2-pre9/Makefile.am 2005-09-20 22:09:03.000000000 +0000 | ||
25 | @@ -21,13 +21,14 @@ | ||
26 | MAN5 = modprobe.conf.5 modules.dep.5 | ||
27 | MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8 | ||
28 | SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml)) | ||
29 | -man_MANS = $(MAN5) $(MAN8) | ||
30 | # If they haven't overridden mandir, fix it (never /man!) | ||
31 | mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi) | ||
32 | |||
33 | TESTSUITE := $(shell find tests -type f ! -name '*~') tests/vg-suppressions | ||
34 | |||
35 | -EXTRA_DIST = generate-modprobe.conf modprobe.devfs FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE) | ||
36 | +if MANPAGES | ||
37 | +man_MANS = $(MAN5) $(MAN8) | ||
38 | +endif | ||
39 | |||
40 | sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo insmod.static | ||
41 | bin_PROGRAMS = lsmod | ||
diff --git a/openembedded/packages/module-init-tools/module-init-tools-cross_3.1.bb b/openembedded/packages/module-init-tools/module-init-tools-cross_3.1.bb deleted file mode 100644 index 56fec56072..0000000000 --- a/openembedded/packages/module-init-tools/module-init-tools-cross_3.1.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | LICENSE = "GPL" | ||
2 | include module-init-tools_${PV}.bb | ||
3 | inherit cross | ||
4 | DEFAULT_PREFERENCE = "0" | ||
5 | PROVIDES += "virtual/${TARGET_PREFIX}depmod virtual/${TARGET_PREFIX}depmod-2.6" | ||
6 | |||
7 | PR="r3" | ||
8 | |||
9 | # When cross compiling depmod as shipped cannot handle endian | ||
10 | # differences between host and target, this fixes the problem. | ||
11 | # It also solves any possible issues with alignment (only likely | ||
12 | # if cross compiling for a low alignment target - e.g. x86, on | ||
13 | # a high alignment host - e.g. SPARC). | ||
14 | SRC_URI += " file://depmod-byteswap.patch;patch=1 " | ||
15 | |||
16 | EXTRA_OECONF_append = " --program-prefix=${TARGET_PREFIX}" | ||
17 | |||
18 | do_stage () { | ||
19 | oe_runmake install | ||
20 | } | ||
21 | |||
22 | do_install () { | ||
23 | : | ||
24 | } | ||
diff --git a/openembedded/packages/module-init-tools/module-init-tools-cross_3.2.2.bb b/openembedded/packages/module-init-tools/module-init-tools-cross_3.2.2.bb new file mode 100644 index 0000000000..4bcc311709 --- /dev/null +++ b/openembedded/packages/module-init-tools/module-init-tools-cross_3.2.2.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | LICENSE = "GPL" | ||
2 | include module-init-tools_${PV}.bb | ||
3 | inherit cross | ||
4 | DEFAULT_PREFERENCE = "0" | ||
5 | PROVIDES += "virtual/${TARGET_PREFIX}depmod virtual/${TARGET_PREFIX}depmod-2.6" | ||
6 | |||
7 | EXTRA_OECONF_append = " --program-prefix=${TARGET_PREFIX}" | ||
8 | |||
9 | do_stage () { | ||
10 | oe_runmake install | ||
11 | } | ||
12 | |||
13 | do_install () { | ||
14 | : | ||
15 | } | ||
diff --git a/openembedded/packages/module-init-tools/module-init-tools_3.1.bb b/openembedded/packages/module-init-tools/module-init-tools_3.1.bb deleted file mode 100644 index 62523f513a..0000000000 --- a/openembedded/packages/module-init-tools/module-init-tools_3.1.bb +++ /dev/null | |||
@@ -1,60 +0,0 @@ | |||
1 | LICENSE = "GPL" | ||
2 | SECTION = "base" | ||
3 | DESCRIPTION = "This package contains a set of programs for loading, inserting, and \ | ||
4 | removing kernel modules for Linux (versions 2.5.48 and above). It serves \ | ||
5 | the same function that the modutils package serves for Linux 2.4." | ||
6 | PR = "r2" | ||
7 | |||
8 | PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod" | ||
9 | RDEPENDS_${PN} += "module-init-tools-depmod" | ||
10 | |||
11 | FILES_module-init-tools-depmod = "${sbindir}/depmod.26" | ||
12 | FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static" | ||
13 | |||
14 | SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \ | ||
15 | file://ignore_arch_directory;patch=1 \ | ||
16 | file://modutils_extension;patch=1 \ | ||
17 | file://no_man_rebuild;patch=1 \ | ||
18 | file://manpagesopt;patch=1 \ | ||
19 | file://soc.patch;patch=1;pnum=0" | ||
20 | S = "${WORKDIR}/module-init-tools-${PV}" | ||
21 | |||
22 | EXTRA_OECONF = "--disable-manpages" | ||
23 | |||
24 | bindir = "/bin" | ||
25 | sbindir = "/sbin" | ||
26 | |||
27 | inherit autotools | ||
28 | |||
29 | do_install() { | ||
30 | autotools_do_install | ||
31 | for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do | ||
32 | mv ${D}/$f ${D}/$f.26 | ||
33 | done | ||
34 | } | ||
35 | |||
36 | pkg_postinst_module-init-tools() { | ||
37 | #!/bin/sh | ||
38 | for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do | ||
39 | bn=`basename $f` | ||
40 | update-alternatives --install /$f $bn /$f.26 20 | ||
41 | done | ||
42 | } | ||
43 | |||
44 | pkg_prerm_module-init-tools() { | ||
45 | #!/bin/sh | ||
46 | for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do | ||
47 | bn=`basename $f` | ||
48 | update-alternatives --remove $bn /$f.26 | ||
49 | done | ||
50 | } | ||
51 | |||
52 | pkg_postinst_module-init-tools-depmod() { | ||
53 | #!/bin/sh | ||
54 | update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 20 | ||
55 | } | ||
56 | |||
57 | pkg_prerm_module-init-tools() { | ||
58 | #!/bin/sh | ||
59 | update-alternatives --remove depmod /sbin/depmod.26 | ||
60 | } | ||
diff --git a/openembedded/packages/module-init-tools/module-init-tools_3.2.1.bb b/openembedded/packages/module-init-tools/module-init-tools_3.2.2.bb index bbd8cca1bf..bbd8cca1bf 100644 --- a/openembedded/packages/module-init-tools/module-init-tools_3.2.1.bb +++ b/openembedded/packages/module-init-tools/module-init-tools_3.2.2.bb | |||