diff options
Diffstat (limited to 'openembedded/packages/meta/task-bootstrap.bb')
-rw-r--r-- | openembedded/packages/meta/task-bootstrap.bb | 36 |
1 files changed, 0 insertions, 36 deletions
diff --git a/openembedded/packages/meta/task-bootstrap.bb b/openembedded/packages/meta/task-bootstrap.bb deleted file mode 100644 index 497fc31d89..0000000000 --- a/openembedded/packages/meta/task-bootstrap.bb +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | DESCRIPTION = "Core packages required for a basic installation" | ||
2 | MAINTAINER = "Phil Blundell <pb@handhelds.org>" | ||
3 | PR = "r26" | ||
4 | |||
5 | # The BOOTSTRAP_EXTRA_ variables are often manipulated by the | ||
6 | # MACHINE .conf files, so adjust PACKAGE_ARCH accordingly. | ||
7 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
8 | |||
9 | ALLOW_EMPTY = 1 | ||
10 | PACKAGES = "${PN}" | ||
11 | |||
12 | MODUTILS ?= "24 26" | ||
13 | |||
14 | def bootstrap_modutils_rdepends(d): | ||
15 | import bb | ||
16 | m = bb.data.getVar('MODUTILS', d, 1) | ||
17 | r = [] | ||
18 | if '24' in m: | ||
19 | r.append('modutils-depmod') | ||
20 | if '26' in m: | ||
21 | r.append('module-init-tools-depmod') | ||
22 | return ' '.join(r) | ||
23 | |||
24 | HOTPLUG ?= "linux-hotplug" | ||
25 | |||
26 | RDEPENDS = 'base-files base-passwd busybox \ | ||
27 | initscripts \ | ||
28 | netbase sysvinit sysvinit-pidof tinylogin \ | ||
29 | modutils-initscripts fuser setserial\ | ||
30 | ${HOTPLUG} \ | ||
31 | ${BOOTSTRAP_EXTRA_RDEPENDS} \ | ||
32 | ${@bootstrap_modutils_rdepends(d)}' | ||
33 | |||
34 | RRECOMMENDS = 'dropbear portmap \ | ||
35 | ${BOOTSTRAP_EXTRA_RRECOMMENDS}' | ||
36 | LICENSE = MIT | ||