diff options
Diffstat (limited to 'openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch')
-rw-r--r-- | openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch | 59 |
1 files changed, 59 insertions, 0 deletions
diff --git a/openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch b/openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch new file mode 100644 index 0000000000..68abc7dda4 --- /dev/null +++ b/openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch | |||
@@ -0,0 +1,59 @@ | |||
1 | Index: ltt-modules-0.12/ltt-statedump.c | ||
2 | =================================================================== | ||
3 | --- ltt-modules-0.12.orig/ltt-statedump.c 2006-03-09 19:33:38.000000000 +0000 | ||
4 | +++ ltt-modules-0.12/ltt-statedump.c 2006-03-22 12:43:30.000000000 +0000 | ||
5 | @@ -19,8 +19,14 @@ | ||
6 | #include <linux/proc_fs.h> | ||
7 | #include <linux/file.h> | ||
8 | #include <linux/interrupt.h> | ||
9 | -#include <linux/irq.h> | ||
10 | #include <linux/ltt/ltt-facility-statedump.h> | ||
11 | +#ifndef CONFIG_ARM | ||
12 | +#include <linux/irq.h> | ||
13 | +#else | ||
14 | +#include <asm/mach/irq.h> | ||
15 | +#endif | ||
16 | + | ||
17 | + | ||
18 | |||
19 | #define NB_PROC_CHUNK 20 | ||
20 | |||
21 | @@ -160,6 +166,7 @@ | ||
22 | return 0; | ||
23 | } | ||
24 | |||
25 | +#ifndef CONFIG_ARM | ||
26 | static inline int ltt_enumerate_interrupts(void) | ||
27 | { | ||
28 | unsigned int i; | ||
29 | @@ -182,7 +189,9 @@ | ||
30 | |||
31 | return 0; | ||
32 | } | ||
33 | - | ||
34 | +#else | ||
35 | +#define ltt_enumerate_interrupts(x) | ||
36 | +#endif | ||
37 | |||
38 | static inline int ltt_enumerate_process_states(void) | ||
39 | { | ||
40 | Index: ltt-modules-0.12/Makefile | ||
41 | =================================================================== | ||
42 | --- ltt-modules-0.12.orig/Makefile 2006-03-11 18:16:17.000000000 +0000 | ||
43 | +++ ltt-modules-0.12/Makefile 2006-03-22 12:39:44.000000000 +0000 | ||
44 | @@ -1,9 +1,7 @@ | ||
45 | -ifneq ($(KERNELRELEASE),) | ||
46 | ifneq ($(CONFIG_LTT),) | ||
47 | obj-m := ltt-control.o ltt-statedump.o | ||
48 | endif | ||
49 | |||
50 | -else | ||
51 | KERNELDIR ?= /lib/modules/$(shell uname -r)/build | ||
52 | PWD := $(shell pwd) | ||
53 | KERNELRELEASE = $(shell cat $(KERNELDIR)/$(KBUILD_OUTPUT)/include/linux/version.h | sed -n 's/.*UTS_RELEASE.*\"\(.*\)\".*/\1/p') | ||
54 | @@ -21,4 +19,4 @@ | ||
55 | |||
56 | clean: | ||
57 | $(MAKE) -C $(KERNELDIR) M=$(PWD) clean | ||
58 | -endif | ||
59 | + | ||