summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/linux/linux-omap1_2.6.12-rc2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/linux/linux-omap1_2.6.12-rc2.bb')
-rw-r--r--openembedded/packages/linux/linux-omap1_2.6.12-rc2.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/openembedded/packages/linux/linux-omap1_2.6.12-rc2.bb b/openembedded/packages/linux/linux-omap1_2.6.12-rc2.bb
new file mode 100644
index 0000000000..adac637caf
--- /dev/null
+++ b/openembedded/packages/linux/linux-omap1_2.6.12-rc2.bb
@@ -0,0 +1,46 @@
1PR = "r3"
2SECTION = "kernel"
3DESCRIPTION = "Linux kernel for OMAP processors"
4LICENSE = "GPL"
5
6SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/testing/linux-2.6.12-rc2.tar.bz2 \
7 http://www.muru.com/linux/omap/patches/patch-2.6.12-rc2-omap1.bz2;patch=1 \
8 file://defconfig"
9
10
11S = "${WORKDIR}/linux-2.6.12-rc2"
12
13KERNEL_IMAGETYPE = "vmlinux"
14KERNEL_OUTPUT = "arch/${ARCH}/boot/compressed/${KERNEL_IMAGETYPE}"
15#KERNEL_CCSUFFIX = "-3.3.4"
16
17#DEPENDS = "uboot"
18
19inherit kernel
20
21python __anonymous () {
22 import re
23 host = bb.data.getVar('HOST_SYS', d, 1)
24 if not re.match('arm.*-linux', host):
25 raise bb.parse.SkipPackage("incompatible with host %s" % host)
26}
27
28
29do_configure_prepend() {
30 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
31 oe_runmake oldconfig
32}
33
34do_deploy_omap5912osk() {
35 install -d ${DEPLOY_DIR}/images
36 arm-linux-objcopy -O binary -R .note -R .comment -S arch/arm/boot/compressed/vmlinux ${DEPLOY_DIR}/linux.bin
37 gzip -f -9 ${DEPLOY_DIR}/linux.bin
38 mkimage -A arm -O linux -T kernel -C gzip -a 0x10c08000 -e 0x10c08000 -n "OE" -d ${DEPLOY_DIR}/linux.bin.gz ${DEPLOY_DIR}/uImage_bb.cc
39 cp ${DEPLOY_DIR}/uImage_bb.cc /tftpboot
40# install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
41}
42
43
44do_deploy[dirs] = "${S}"
45
46addtask deploy before do_build after do_compile