summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/linux-libc-headers
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/linux-libc-headers')
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch72
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff11
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb6
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb56
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb61
5 files changed, 3 insertions, 203 deletions
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch b/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch
deleted file mode 100644
index e97650a9de..0000000000
--- a/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch
+++ /dev/null
@@ -1,72 +0,0 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- /dev/null 2004-06-02 16:28:12.000000000 -0500
7+++ linux-libc-headers-2.6.7.0/include/asm-sh/cpu-sh4/sigcontext.h 2004-08-27 17:56:59.000000000 -0500
8@@ -0,0 +1,24 @@
9+#ifndef __ASM_CPU_SH4_SIGCONTEXT_H
10+#define __ASM_CPU_SH4_SIGCONTEXT_H
11+
12+struct sigcontext {
13+ unsigned long oldmask;
14+
15+ /* CPU registers */
16+ unsigned long sc_regs[16];
17+ unsigned long sc_pc;
18+ unsigned long sc_pr;
19+ unsigned long sc_sr;
20+ unsigned long sc_gbr;
21+ unsigned long sc_mach;
22+ unsigned long sc_macl;
23+
24+ /* FPU registers */
25+ unsigned long sc_fpregs[16];
26+ unsigned long sc_xfpregs[16];
27+ unsigned int sc_fpscr;
28+ unsigned int sc_fpul;
29+ unsigned int sc_ownedfp;
30+};
31+
32+#endif /* __ASM_CPU_SH4_SIGCONTEXT_H */
33--- /dev/null 2004-06-02 16:28:12.000000000 -0500
34+++ linux-libc-headers-2.6.7.0/include/asm-sh/cpu-sh2/sigcontext.h 2004-08-27 17:57:54.000000000 -0500
35@@ -0,0 +1,17 @@
36+#ifndef __ASM_CPU_SH2_SIGCONTEXT_H
37+#define __ASM_CPU_SH2_SIGCONTEXT_H
38+
39+struct sigcontext {
40+ unsigned long oldmask;
41+
42+ /* CPU registers */
43+ unsigned long sc_regs[16];
44+ unsigned long sc_pc;
45+ unsigned long sc_pr;
46+ unsigned long sc_sr;
47+ unsigned long sc_gbr;
48+ unsigned long sc_mach;
49+ unsigned long sc_macl;
50+};
51+
52+#endif /* __ASM_CPU_SH2_SIGCONTEXT_H */
53--- /dev/null 2004-06-02 16:28:12.000000000 -0500
54+++ linux-libc-headers-2.6.7.0/include/asm-sh/cpu-sh3/sigcontext.h 2004-08-27 17:57:58.000000000 -0500
55@@ -0,0 +1,17 @@
56+#ifndef __ASM_CPU_SH3_SIGCONTEXT_H
57+#define __ASM_CPU_SH3_SIGCONTEXT_H
58+
59+struct sigcontext {
60+ unsigned long oldmask;
61+
62+ /* CPU registers */
63+ unsigned long sc_regs[16];
64+ unsigned long sc_pc;
65+ unsigned long sc_pr;
66+ unsigned long sc_sr;
67+ unsigned long sc_gbr;
68+ unsigned long sc_mach;
69+ unsigned long sc_macl;
70+};
71+
72+#endif /* __ASM_CPU_SH3_SIGCONTEXT_H */
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff b/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff
deleted file mode 100644
index a06b5affd9..0000000000
--- a/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff
+++ /dev/null
@@ -1,11 +0,0 @@
1--- include/asm-mips/atomic.h.orig 2004-10-01 10:10:05.487734944 +0200
2+++ include/asm-mips/atomic.h 2004-10-01 10:10:15.837161592 +0200
3@@ -15,8 +15,6 @@
4 #define _ASM_ATOMIC_H
5
6
7-#include <asm/system.h>
8-
9 typedef struct { volatile int counter; } atomic_t;
10 typedef struct { volatile __s64 counter; } atomic64_t;
11
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
index c7d6367c7b..65e3f8b25b 100644
--- a/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
+++ b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
@@ -36,11 +36,11 @@ do_configure () {
36 if test ! -e include/asm-$ARCH; then 36 if test ! -e include/asm-$ARCH; then
37 oefatal unable to create asm symlink in kernel headers 37 oefatal unable to create asm symlink in kernel headers
38 fi 38 fi
39 cp -a "include/asm-$ARCH" "include/asm" 39 cp -pPR "include/asm-$ARCH" "include/asm"
40 if test "$ARCH" = "arm"; then 40 if test "$ARCH" = "arm"; then
41 cp -a include/asm/arch-ebsa285 include/asm/arch 41 cp -pPR include/asm/arch-ebsa285 include/asm/arch
42 elif test "$ARCH" = "sh"; then 42 elif test "$ARCH" = "sh"; then
43 cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu" 43 cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
44 fi 44 fi
45} 45}
46 46
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
deleted file mode 100644
index f881d38a34..0000000000
--- a/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1SECTION = "devel"
2DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
3MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
4INHIBIT_DEFAULT_DEPS = "1"
5PR = "r3"
6LICENSE = "GPL"
7# NOTE: no need to package these headers, since the c library includes them.
8PACKAGES = ""
9
10SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
11 file://sh-missing.patch;patch=1 \
12 file://keyboard.patch;patch=1"
13S = "${WORKDIR}/linux-libc-headers-${PV}"
14
15do_configure () {
16 case ${TARGET_ARCH} in
17 alpha*) ARCH=alpha ;;
18 arm*) ARCH=arm ;;
19 cris*) ARCH=cris ;;
20 hppa*) ARCH=parisc ;;
21 i*86*) ARCH=i386 ;;
22 ia64*) ARCH=ia64 ;;
23 mips*) ARCH=mips ;;
24 m68k*) ARCH=m68k ;;
25 powerpc*) ARCH=ppc ;;
26 s390*) ARCH=s390 ;;
27 sh*) ARCH=sh ;;
28 sparc64*) ARCH=sparc64 ;;
29 sparc*) ARCH=sparc ;;
30 x86_64*) ARCH=x86_64 ;;
31 esac
32 if test ! -e include/asm-$ARCH; then
33 oefatal unable to create asm symlink in kernel headers
34 fi
35 cp -a "include/asm-$ARCH" "include/asm"
36 if test "$ARCH" = "arm"; then
37 cp -a include/asm/arch-ebsa285 include/asm/arch
38 elif test "$ARCH" = "sh"; then
39 cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
40 fi
41}
42
43do_stage () {
44 install -d ${STAGING_INCDIR}
45 rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
46 cp -pfLR include/linux ${STAGING_INCDIR}/
47 cp -pfLR include/asm ${STAGING_INCDIR}/
48 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
49 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
50 install -d ${CROSS_DIR}/${TARGET_SYS}/include
51 cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
52 cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
53
54 ln -sf ${STAGING_KERNEL_DIR}/include/linux/wireless.h ${STAGING_INCDIR}/linux/wireless.h
55 ln -sf ${STAGING_KERNEL_DIR}/include/linux/wireless.h ${CROSS_DIR}/${TARGET_SYS}/include/linux/wireless.h
56}
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
deleted file mode 100644
index c127e8a9e7..0000000000
--- a/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
+++ /dev/null
@@ -1,61 +0,0 @@
1SECTION = "devel"
2DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
3HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
4# license note from the package:
5# Linux-libc-headers are derived from linux kernel headers. For license of a
6# particular header, check it's content, and if copyright notice isn't present,
7# standard linux kernel license applies.
8# since we assume GPL for linux i think we can also assume it here
9LICENSE = "GPL"
10MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
11INHIBIT_DEFAULT_DEPS = "1"
12PR = "r7"
13
14# NOTE: no need to package these headers, since the c library includes them.
15PACKAGES = ""
16
17SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
18 file://mips-asm-atomic-system.diff;patch=1;pnum=0 \
19 file://keyboard.patch;patch=1"
20
21S = "${WORKDIR}/linux-libc-headers-${PV}"
22
23do_configure () {
24 case ${TARGET_ARCH} in
25 alpha*) ARCH=alpha ;;
26 arm*) ARCH=arm ;;
27 cris*) ARCH=cris ;;
28 hppa*) ARCH=parisc ;;
29 i*86*) ARCH=i386 ;;
30 ia64*) ARCH=ia64 ;;
31 mips*) ARCH=mips ;;
32 m68k*) ARCH=m68k ;;
33 powerpc*) ARCH=ppc ;;
34 s390*) ARCH=s390 ;;
35 sh*) ARCH=sh ;;
36 sparc64*) ARCH=sparc64 ;;
37 sparc*) ARCH=sparc ;;
38 x86_64*) ARCH=x86_64 ;;
39 esac
40 if test ! -e include/asm-$ARCH; then
41 oefatal unable to create asm symlink in kernel headers
42 fi
43 cp -a "include/asm-$ARCH" "include/asm"
44 if test "$ARCH" = "arm"; then
45 cp -a include/asm/arch-ebsa285 include/asm/arch
46 elif test "$ARCH" = "sh"; then
47 cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
48 fi
49}
50
51do_stage () {
52 install -d ${STAGING_INCDIR}
53 rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
54 cp -pfLR include/linux ${STAGING_INCDIR}/
55 cp -pfLR include/asm ${STAGING_INCDIR}/
56 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
57 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
58 install -d ${CROSS_DIR}/${TARGET_SYS}/include
59 cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
60 cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
61}