diff options
Diffstat (limited to 'openembedded/packages/ipkg')
28 files changed, 0 insertions, 605 deletions
diff --git a/openembedded/packages/ipkg/ipkg-0.99.129/buffer-overflow.patch b/openembedded/packages/ipkg/ipkg-0.99.129/buffer-overflow.patch deleted file mode 100644 index 91234fd53f..0000000000 --- a/openembedded/packages/ipkg/ipkg-0.99.129/buffer-overflow.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | Index: ipkg_cmd.c | ||
2 | =================================================================== | ||
3 | RCS file: /cvs/familiar/dist/ipkg/C/ipkg_cmd.c,v | ||
4 | retrieving revision 1.96 | ||
5 | diff -u -r1.96 ipkg_cmd.c | ||
6 | --- C/ipkg_cmd.c 19 Aug 2004 10:55:47 -0000 1.96 | ||
7 | +++ C/ipkg_cmd.c 11 Sep 2004 19:43:14 -0000 | ||
8 | @@ -860,6 +860,7 @@ | ||
9 | str_list_elt_t *iter; | ||
10 | char *pkg_version; | ||
11 | size_t buff_len = 8192; | ||
12 | + size_t used_len; | ||
13 | char *buff ; | ||
14 | |||
15 | buff = (char *)malloc(buff_len); | ||
16 | @@ -891,9 +892,20 @@ | ||
17 | } | ||
18 | #else | ||
19 | if (buff) { | ||
20 | - snprintf(buff, buff_len, "Package %s (%s) is installed on %s and has the following files:\n", | ||
21 | - pkg->name, pkg_version, pkg->dest->name); | ||
22 | + try_again: | ||
23 | + used_len = snprintf(buff, buff_len, "Package %s (%s) is installed on %s and has the following files:\n", | ||
24 | + pkg->name, pkg_version, pkg->dest->name) + 1; | ||
25 | + if (used_len > buff_len) { | ||
26 | + buff_len *= 2; | ||
27 | + buff = realloc (buff, buff_len); | ||
28 | + goto try_again; | ||
29 | + } | ||
30 | for (iter = installed_files->head; iter; iter = iter->next) { | ||
31 | + used_len += strlen (iter->data) + 1; | ||
32 | + while (buff_len <= used_len) { | ||
33 | + buff_len *= 2; | ||
34 | + buff = realloc (buff, buff_len); | ||
35 | + } | ||
36 | strncat(buff, iter->data, buff_len); | ||
37 | strncat(buff, "\n", buff_len); | ||
38 | } | ||
diff --git a/openembedded/packages/ipkg/ipkg-0.99.130/terse.patch b/openembedded/packages/ipkg/ipkg-0.99.130/terse.patch deleted file mode 100644 index 9a07df5df3..0000000000 --- a/openembedded/packages/ipkg/ipkg-0.99.130/terse.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- C/ipkg_cmd.c~terse | ||
7 | +++ C/ipkg_cmd.c | ||
8 | @@ -119,8 +119,6 @@ | ||
9 | " writing status file\n"); | ||
10 | ipkg_conf_write_status_files(conf); | ||
11 | pkg_write_changed_filelists(conf); | ||
12 | - } else { | ||
13 | - ipkg_message(conf, IPKG_NOTICE, "Nothing to be done\n"); | ||
14 | } | ||
15 | } | ||
16 | |||
17 | @@ -148,9 +146,7 @@ | ||
18 | int result; | ||
19 | p_userdata = userdata; | ||
20 | result = (cmd->fun)(conf, argc, argv); | ||
21 | - if ( result == 0 ) { | ||
22 | - ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n"); | ||
23 | - } else { | ||
24 | + if ( result != 0 ) { | ||
25 | ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result); | ||
26 | } | ||
27 | |||
diff --git a/openembedded/packages/ipkg/ipkg-0.99.135/depends.patch b/openembedded/packages/ipkg/ipkg-0.99.135/depends.patch deleted file mode 100644 index 8f472ab405..0000000000 --- a/openembedded/packages/ipkg/ipkg-0.99.135/depends.patch +++ /dev/null | |||
@@ -1,107 +0,0 @@ | |||
1 | Index: ipkg_cmd.c | ||
2 | =================================================================== | ||
3 | RCS file: /cvs/familiar/dist/ipkg/C/ipkg_cmd.c,v | ||
4 | retrieving revision 1.99 | ||
5 | diff -u -r1.99 ipkg_cmd.c | ||
6 | --- ipkg/ipkg_cmd.c 6 Jan 2005 00:21:49 -0000 1.99 | ||
7 | +++ ipkg/ipkg_cmd.c 8 Jan 2005 13:11:16 -0000 | ||
8 | @@ -1150,7 +1150,7 @@ | ||
9 | |||
10 | int pkg_mark_provides(pkg_t *pkg) | ||
11 | { | ||
12 | - int provides_count = pkg->provides_count; | ||
13 | + int provides_count = pkg->provides_count + 1; | ||
14 | abstract_pkg_t **provides = pkg->provides; | ||
15 | int i; | ||
16 | pkg->parent->state_flag |= SF_MARKED; | ||
17 | @@ -1207,7 +1207,7 @@ | ||
18 | for (j = 0; j < available_pkgs->len; j++) { | ||
19 | pkg_t *pkg = available_pkgs->pkgs[j]; | ||
20 | int k; | ||
21 | - int count = (what_field_type == WHATPROVIDES) ? pkg->provides_count : pkg->replaces_count; | ||
22 | + int count = (what_field_type == WHATPROVIDES) ? pkg->provides_count + 1 : pkg->replaces_count; | ||
23 | for (k = 0; k < count; k++) { | ||
24 | abstract_pkg_t *apkg = | ||
25 | ((what_field_type == WHATPROVIDES) | ||
26 | Index: ipkg_remove.c | ||
27 | =================================================================== | ||
28 | RCS file: /cvs/familiar/dist/ipkg/C/ipkg_remove.c,v | ||
29 | retrieving revision 1.40 | ||
30 | diff -u -r1.40 ipkg_remove.c | ||
31 | --- ipkg/ipkg_remove.c 10 May 2004 21:37:07 -0000 1.40 | ||
32 | +++ ipkg/ipkg_remove.c 8 Jan 2005 13:11:19 -0000 | ||
33 | @@ -39,7 +39,7 @@ | ||
34 | */ | ||
35 | int pkg_has_installed_dependents(ipkg_conf_t *conf, abstract_pkg_t *parent_apkg, pkg_t *pkg, abstract_pkg_t *** pdependents) | ||
36 | { | ||
37 | - int nprovides = pkg->provides_count; | ||
38 | + int nprovides = pkg->provides_count + 1; | ||
39 | abstract_pkg_t **provides = pkg->provides; | ||
40 | int n_installed_dependents = 0; | ||
41 | int i; | ||
42 | Index: pkg_depends.c | ||
43 | =================================================================== | ||
44 | RCS file: /cvs/familiar/dist/ipkg/C/pkg_depends.c,v | ||
45 | retrieving revision 1.61 | ||
46 | diff -u -r1.61 pkg_depends.c | ||
47 | --- ipkg/pkg_depends.c 1 Sep 2004 20:30:39 -0000 1.61 | ||
48 | +++ ipkg/pkg_depends.c 8 Jan 2005 13:11:21 -0000 | ||
49 | @@ -420,9 +420,9 @@ | ||
50 | int pkg_has_common_provides(pkg_t *pkg, pkg_t *replacee) | ||
51 | { | ||
52 | abstract_pkg_t **provides = pkg->provides; | ||
53 | - int provides_count = pkg->provides_count; | ||
54 | + int provides_count = pkg->provides_count + 1; | ||
55 | abstract_pkg_t **replacee_provides = replacee->provides; | ||
56 | - int replacee_provides_count = replacee->provides_count; | ||
57 | + int replacee_provides_count = replacee->provides_count + 1; | ||
58 | int i, j; | ||
59 | for (i = 0; i < provides_count; i++) { | ||
60 | abstract_pkg_t *apkg = provides[i]; | ||
61 | @@ -443,7 +443,7 @@ | ||
62 | int pkg_provides_abstract(pkg_t *pkg, abstract_pkg_t *providee) | ||
63 | { | ||
64 | abstract_pkg_t **provides = pkg->provides; | ||
65 | - int provides_count = pkg->provides_count; | ||
66 | + int provides_count = pkg->provides_count + 1; | ||
67 | int i; | ||
68 | for (i = 0; i < provides_count; i++) { | ||
69 | if (provides[i] == providee) | ||
70 | @@ -461,7 +461,7 @@ | ||
71 | abstract_pkg_t **replaces = pkg->replaces; | ||
72 | int replaces_count = pkg->replaces_count; | ||
73 | abstract_pkg_t **replacee_provides = pkg->provides; | ||
74 | - int replacee_provides_count = pkg->provides_count; | ||
75 | + int replacee_provides_count = pkg->provides_count + 1; | ||
76 | int i, j; | ||
77 | for (i = 0; i < replaces_count; i++) { | ||
78 | abstract_pkg_t *abstract_replacee = replaces[i]; | ||
79 | @@ -504,7 +504,7 @@ | ||
80 | compound_depend_t *conflicts = pkg->conflicts; | ||
81 | int conflicts_count = pkg->conflicts_count; | ||
82 | abstract_pkg_t **conflictee_provides = conflictee->provides; | ||
83 | - int conflictee_provides_count = conflictee->provides_count; | ||
84 | + int conflictee_provides_count = conflictee->provides_count + 1; | ||
85 | int i, j, k; | ||
86 | for (i = 0; i < conflicts_count; i++) { | ||
87 | int possibility_count = conflicts[i].possibility_count; | ||
88 | @@ -605,9 +605,6 @@ | ||
89 | /* every pkg provides itself */ | ||
90 | abstract_pkg_vec_insert(ab_pkg->provided_by, ab_pkg); | ||
91 | |||
92 | - if (!pkg->provides_count) | ||
93 | - return 0; | ||
94 | - | ||
95 | pkg->provides = (abstract_pkg_t **)malloc(sizeof(abstract_pkg_t *) * (pkg->provides_count + 1)); | ||
96 | if (pkg->provides == NULL) { | ||
97 | fprintf(stderr, "%s: out of memory\n", __FUNCTION__); | ||
98 | @@ -615,6 +612,9 @@ | ||
99 | } | ||
100 | pkg->provides[0] = ab_pkg; | ||
101 | |||
102 | + if (pkg->provides_count == 0) | ||
103 | + return 0; | ||
104 | + | ||
105 | // if (strcmp(ab_pkg->name, pkg->name)) | ||
106 | // fprintf(stderr, __FUNCTION__ ": ab_pkg=%s pkg=%s\n", ab_pkg->name, pkg->name); | ||
107 | |||
diff --git a/openembedded/packages/ipkg/ipkg-0.99.135/remove-c99isms.patch b/openembedded/packages/ipkg/ipkg-0.99.135/remove-c99isms.patch deleted file mode 100644 index e70f3af9ff..0000000000 --- a/openembedded/packages/ipkg/ipkg-0.99.135/remove-c99isms.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- C/ipkg_install.c~remove-c99isms.patch | ||
7 | +++ C/ipkg_install.c | ||
8 | @@ -186,14 +186,16 @@ | ||
9 | { | ||
10 | abstract_pkg_vec_t *providers = pkg_hash_fetch_all_installation_candidates (&conf->pkg_hash, pkg_name); | ||
11 | int i; | ||
12 | + ipkg_error_t err; | ||
13 | + abstract_pkg_t *ppkg; | ||
14 | |||
15 | if (providers == NULL) | ||
16 | return IPKG_PKG_HAS_NO_CANDIDATE; | ||
17 | |||
18 | for (i = 0; i < providers->len; i++) { | ||
19 | - abstract_pkg_t *ppkg = abstract_pkg_vec_get(providers, i); | ||
20 | - ipkg_message(conf, IPKG_DEBUG2,"Function: %s calling ipkg_install_by_name %d \n",__FUNCTION__, i); | ||
21 | - ipkg_error_t err = ipkg_install_by_name(conf, ppkg->name); | ||
22 | + ppkg = abstract_pkg_vec_get(providers, i); | ||
23 | + ipkg_message(conf, IPKG_DEBUG2,"Function: %s calling ipkg_install_by_name %d \n",__FUNCTION__, i); | ||
24 | + err = ipkg_install_by_name(conf, ppkg->name); | ||
25 | if (err) | ||
26 | return err; | ||
27 | } | ||
28 | @@ -614,12 +616,13 @@ | ||
29 | int pkg_remove_installed_replacees_unwind(ipkg_conf_t *conf, pkg_vec_t *replacees) | ||
30 | { | ||
31 | int i; | ||
32 | + int err; | ||
33 | int replaces_count = replacees->len; | ||
34 | for (i = 0; i < replaces_count; i++) { | ||
35 | pkg_t *replacee = replacees->pkgs[i]; | ||
36 | if (replacee->state_status != SS_INSTALLED) { | ||
37 | ipkg_message(conf, IPKG_DEBUG2,"Function: %s calling ipkg_install_pkg \n",__FUNCTION__); | ||
38 | - int err = ipkg_install_pkg(conf, replacee); | ||
39 | + err = ipkg_install_pkg(conf, replacee); | ||
40 | if (err) | ||
41 | return err; | ||
42 | } | ||
diff --git a/openembedded/packages/ipkg/ipkg-0.99.140/remove-c99isms.patch b/openembedded/packages/ipkg/ipkg-0.99.140/remove-c99isms.patch deleted file mode 100644 index f1ad2a3f6c..0000000000 --- a/openembedded/packages/ipkg/ipkg-0.99.140/remove-c99isms.patch +++ /dev/null | |||
@@ -1,124 +0,0 @@ | |||
1 | Index: C/pkg_depends.c | ||
2 | =================================================================== | ||
3 | --- C.orig/pkg_depends.c 2005-02-08 14:32:46.000000000 +0000 | ||
4 | +++ C/pkg_depends.c 2005-02-08 15:50:50.000000000 +0000 | ||
5 | @@ -251,15 +251,16 @@ | ||
6 | really conflicts | ||
7 | returns 0 if conflicts <> replaces or 1 if conflicts == replaces | ||
8 | */ | ||
9 | -int is_pkg_a_replaces(pkg_t *pkg_scout,pkg_t *pkg){ | ||
10 | - | ||
11 | -int i ; | ||
12 | -int replaces_count = pkg->replaces_count; | ||
13 | +int is_pkg_a_replaces(pkg_t *pkg_scout,pkg_t *pkg) | ||
14 | +{ | ||
15 | + int i ; | ||
16 | + int replaces_count = pkg->replaces_count; | ||
17 | + abstract_pkg_t **replaces; | ||
18 | |||
19 | - if (pkg->replaces_count==0) // No replaces, it's surely a conflict | ||
20 | - return 0; | ||
21 | + if (pkg->replaces_count==0) // No replaces, it's surely a conflict | ||
22 | + return 0; | ||
23 | |||
24 | - abstract_pkg_t **replaces = pkg->replaces; | ||
25 | + replaces = pkg->replaces; | ||
26 | |||
27 | for (i = 0; i < replaces_count; i++) { | ||
28 | if (strcmp(pkg_scout->name,pkg->replaces[i]->name)==0) // Found | ||
29 | @@ -280,6 +281,8 @@ | ||
30 | register int i, j, k; | ||
31 | int count; | ||
32 | abstract_pkg_t * ab_pkg; | ||
33 | + pkg_t **pkg_scouts; | ||
34 | + pkg_t *pkg_scout; | ||
35 | |||
36 | /* | ||
37 | * this is a setup to check for redundant/cyclic dependency checks, | ||
38 | @@ -316,9 +319,9 @@ | ||
39 | if (test_vec) { | ||
40 | /* pkg_vec found, it is an actual package conflict | ||
41 | * cruise this possiblity's pkg_vec looking for an installed version */ | ||
42 | - pkg_t **pkg_scouts = test_vec->pkgs; | ||
43 | + pkg_scouts = test_vec->pkgs; | ||
44 | for(k = 0; k < test_vec->len; k++){ | ||
45 | - pkg_t *pkg_scout = pkg_scouts[k]; | ||
46 | + pkg_scout = pkg_scouts[k]; | ||
47 | if (!pkg_scout) { | ||
48 | fprintf(stderr, "%s: null pkg scout\n", __FUNCTION__); | ||
49 | continue; | ||
50 | @@ -381,13 +384,16 @@ | ||
51 | abstract_pkg_vec_t *provider_apkgs = apkg->provided_by; | ||
52 | int n_providers = provider_apkgs->len; | ||
53 | abstract_pkg_t **apkgs = provider_apkgs->pkgs; | ||
54 | + pkg_vec_t *pkg_vec; | ||
55 | + int n_pkgs ; | ||
56 | int i; | ||
57 | + int j; | ||
58 | + | ||
59 | for (i = 0; i < n_providers; i++) { | ||
60 | abstract_pkg_t *papkg = apkgs[i]; | ||
61 | - pkg_vec_t *pkg_vec = papkg->pkgs; | ||
62 | + pkg_vec = papkg->pkgs; | ||
63 | if (pkg_vec) { | ||
64 | - int n_pkgs = pkg_vec->len; | ||
65 | - int j; | ||
66 | + n_pkgs = pkg_vec->len; | ||
67 | for (j = 0; j < n_pkgs; j++) { | ||
68 | pkg_t *pkg = pkg_vec->pkgs[j]; | ||
69 | if (version_constraints_satisfied(depend, pkg)) { | ||
70 | @@ -406,12 +412,14 @@ | ||
71 | int n_providers = provider_apkgs->len; | ||
72 | abstract_pkg_t **apkgs = provider_apkgs->pkgs; | ||
73 | int i; | ||
74 | + int n_pkgs; | ||
75 | + int j; | ||
76 | + | ||
77 | for (i = 0; i < n_providers; i++) { | ||
78 | abstract_pkg_t *papkg = apkgs[i]; | ||
79 | pkg_vec_t *pkg_vec = papkg->pkgs; | ||
80 | if (pkg_vec) { | ||
81 | - int n_pkgs = pkg_vec->len; | ||
82 | - int j; | ||
83 | + n_pkgs = pkg_vec->len; | ||
84 | for (j = 0; j < n_pkgs; j++) { | ||
85 | pkg_t *pkg = pkg_vec->pkgs[j]; | ||
86 | if (version_constraints_satisfied(depend, pkg)) { | ||
87 | @@ -532,11 +540,15 @@ | ||
88 | abstract_pkg_t **conflictee_provides = conflictee->provides; | ||
89 | int conflictee_provides_count = conflictee->provides_count; | ||
90 | int i, j, k; | ||
91 | + int possibility_count; | ||
92 | + struct depend **possibilities; | ||
93 | + abstract_pkg_t *possibility ; | ||
94 | + | ||
95 | for (i = 0; i < conflicts_count; i++) { | ||
96 | - int possibility_count = conflicts[i].possibility_count; | ||
97 | - struct depend **possibilities = conflicts[i].possibilities; | ||
98 | + possibility_count = conflicts[i].possibility_count; | ||
99 | + possibilities = conflicts[i].possibilities; | ||
100 | for (j = 0; j < possibility_count; j++) { | ||
101 | - abstract_pkg_t *possibility = possibilities[j]->pkg; | ||
102 | + possibility = possibilities[j]->pkg; | ||
103 | for (k = 0; k < conflictee_provides_count; k++) { | ||
104 | if (possibility == conflictee_provides[k]) { | ||
105 | return 1; | ||
106 | @@ -832,6 +844,8 @@ | ||
107 | compound_depend_t * depends; | ||
108 | int count, othercount; | ||
109 | register int i, j; | ||
110 | + abstract_pkg_t * ab_depend; | ||
111 | + abstract_pkg_t ** temp; | ||
112 | |||
113 | count = pkg->pre_depends_count + pkg->depends_count; | ||
114 | depends = pkg->depends; | ||
115 | @@ -843,8 +857,7 @@ | ||
116 | if (0 && pkg->pre_depends_count) | ||
117 | fprintf(stderr, " i=%d possibility_count=%x depends=%p\n", i, depends->possibility_count, depends); | ||
118 | for (j = 0; j < depends->possibility_count; j++){ | ||
119 | - abstract_pkg_t * ab_depend = depends->possibilities[j]->pkg; | ||
120 | - abstract_pkg_t ** temp; | ||
121 | + ab_depend = depends->possibilities[j]->pkg; | ||
122 | if(!ab_depend->depended_upon_by) | ||
123 | ab_depend->depended_upon_by = (abstract_pkg_t **)calloc(1, sizeof(abstract_pkg_t *)); | ||
124 | |||
diff --git a/openembedded/packages/ipkg/ipkg-0.99.144/paths.patch b/openembedded/packages/ipkg/ipkg-0.99.144/paths.patch deleted file mode 100644 index f40131e252..0000000000 --- a/openembedded/packages/ipkg/ipkg-0.99.144/paths.patch +++ /dev/null | |||
@@ -1,193 +0,0 @@ | |||
1 | Index: C/ipkg.h | ||
2 | =================================================================== | ||
3 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
4 | +++ C/ipkg.h 2005-02-25 15:28:24.000000000 -0600 | ||
5 | @@ -0,0 +1,59 @@ | ||
6 | +/* ipkg.h - the itsy package management system | ||
7 | + | ||
8 | + Carl D. Worth | ||
9 | + | ||
10 | + Copyright (C) 2001 University of Southern California | ||
11 | + | ||
12 | + This program is free software; you can redistribute it and/or | ||
13 | + modify it under the terms of the GNU General Public License as | ||
14 | + published by the Free Software Foundation; either version 2, or (at | ||
15 | + your option) any later version. | ||
16 | + | ||
17 | + This program is distributed in the hope that it will be useful, but | ||
18 | + WITHOUT ANY WARRANTY; without even the implied warranty of | ||
19 | + MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU | ||
20 | + General Public License for more details. | ||
21 | +*/ | ||
22 | + | ||
23 | +#ifndef IPKG_H | ||
24 | +#define IPKG_H | ||
25 | + | ||
26 | +#ifdef HAVE_CONFIG_H | ||
27 | +#include "config.h" | ||
28 | +#endif | ||
29 | + | ||
30 | +#if 0 | ||
31 | +#define IPKG_DEBUG_NO_TMP_CLEANUP | ||
32 | +#endif | ||
33 | + | ||
34 | +#include "includes.h" | ||
35 | +#include "ipkg_conf.h" | ||
36 | +#include "ipkg_message.h" | ||
37 | + | ||
38 | +#define IPKG_PKG_EXTENSION ".ipk" | ||
39 | +#define DPKG_PKG_EXTENSION ".deb" | ||
40 | + | ||
41 | +#define IPKG_LEGAL_PKG_NAME_CHARS "abcdefghijklmnopqrstuvwxyz0123456789.+-" | ||
42 | +#define IPKG_PKG_VERSION_SEP_CHAR '_' | ||
43 | + | ||
44 | +#define IPKG_STATE_DIR_PREFIX IPKGDIR | ||
45 | +#define IPKG_LISTS_DIR_SUFFIX "lists" | ||
46 | +#define IPKG_INFO_DIR_SUFFIX "info" | ||
47 | +#define IPKG_STATUS_FILE_SUFFIX "status" | ||
48 | + | ||
49 | +#define IPKG_BACKUP_SUFFIX "-ipkg.backup" | ||
50 | + | ||
51 | +#define IPKG_LIST_DESCRIPTION_LENGTH 128 | ||
52 | + | ||
53 | +enum ipkg_error { | ||
54 | + IPKG_SUCCESS = 0, | ||
55 | + IPKG_PKG_DEPS_UNSATISFIED, | ||
56 | + IPKG_PKG_IS_ESSENTIAL, | ||
57 | + IPKG_PKG_HAS_DEPENDENTS, | ||
58 | + IPKG_PKG_HAS_NO_CANDIDATE | ||
59 | +}; | ||
60 | +typedef enum ipkg_error ipkg_error_t; | ||
61 | + | ||
62 | +extern int ipkg_state_changed; | ||
63 | + | ||
64 | +#endif | ||
65 | Index: C/configure.ac | ||
66 | =================================================================== | ||
67 | --- C.orig/configure.ac 2005-02-25 15:27:58.000000000 -0600 | ||
68 | +++ C/configure.ac 2005-02-25 15:28:00.000000000 -0600 | ||
69 | @@ -10,6 +10,14 @@ | ||
70 | test -f $top_builddir/configure && break | ||
71 | done | ||
72 | |||
73 | +AC_MSG_CHECKING([ipkg data location]) | ||
74 | +AC_ARG_WITH(ipkgdir, | ||
75 | + AS_HELP_STRING([--with-ipkgdir=ARG], | ||
76 | + [Where to look for plugins (default=${libdir}/ipkg)]), | ||
77 | + [ipkgdir=$withval], | ||
78 | + [ipkgdir='${libdir}/ipkg']) | ||
79 | +AC_MSG_RESULT($ipkgdir) | ||
80 | +AC_SUBST(ipkgdir) | ||
81 | |||
82 | # Checks for programs | ||
83 | AC_PROG_AWK | ||
84 | @@ -50,4 +58,4 @@ | ||
85 | AC_FUNC_VPRINTF | ||
86 | AC_CHECK_FUNCS([memmove memset mkdir regcomp strchr strcspn strdup strerror strndup strrchr strstr strtol strtoul sysinfo utime]) | ||
87 | |||
88 | -AC_OUTPUT(Makefile etc/Makefile replace/Makefile familiar/Makefile familiar/control familiar/control-unstripped familiar/libipkg-control familiar/libipkg-dev-control libbb/Makefile libipkg.pc ipkg.h) | ||
89 | +AC_OUTPUT(Makefile etc/Makefile replace/Makefile familiar/Makefile familiar/control familiar/control-unstripped familiar/libipkg-control familiar/libipkg-dev-control libbb/Makefile libipkg.pc) | ||
90 | Index: C/Makefile.am | ||
91 | =================================================================== | ||
92 | --- C.orig/Makefile.am 2005-02-25 15:27:58.000000000 -0600 | ||
93 | +++ C/Makefile.am 2005-02-25 15:28:00.000000000 -0600 | ||
94 | @@ -3,7 +3,8 @@ | ||
95 | |||
96 | HOST_CPU=@host_cpu@ | ||
97 | BUILD_CPU=@build_cpu@ | ||
98 | -ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" | ||
99 | +ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ \ | ||
100 | + -DLIBDIR=\"$(libdir)\" -DIPKGDIR=\"$(ipkgdir)\" -DSYSCONFDIR=\"$(sysconfdir)\" | ||
101 | |||
102 | bin_PROGRAMS = ipkg-cl | ||
103 | |||
104 | Index: C/ipkg_conf.c | ||
105 | =================================================================== | ||
106 | --- C.orig/ipkg_conf.c 2005-03-12 21:08:36.000000000 +1030 | ||
107 | +++ C/ipkg_conf.c 2005-03-12 21:09:46.000000000 +1030 | ||
108 | @@ -103,7+103,7 @@ | ||
109 | nv_pair_list_t tmp_dest_nv_pair_list; | ||
110 | char * lists_dir =NULL; | ||
111 | glob_t globbuf; | ||
112 | - char *etc_ipkg_conf_pattern = "/etc/ipkg/*.conf"; | ||
113 | + char *etc_ipkg_conf_pattern = SYSCONFDIR"/ipkg/*.conf"; | ||
114 | char *pending_dir =NULL; | ||
115 | |||
116 | memset(conf, 0, sizeof(ipkg_conf_t)); | ||
117 | Index: C/args.h | ||
118 | =================================================================== | ||
119 | --- C.orig/args.h 2005-03-12 21:49:31.000000000 +1030 | ||
120 | +++ C/args.h 2005-03-12 21:49:42.000000000 +1030 | ||
121 | @@ -43,7 +43,7 @@ | ||
122 | }; | ||
123 | typedef struct args args_t; | ||
124 | |||
125 | -#define ARGS_DEFAULT_CONF_FILE_DIR "/etc" | ||
126 | +#define ARGS_DEFAULT_CONF_FILE_DIR SYSCONFDIR | ||
127 | #define ARGS_DEFAULT_CONF_FILE_NAME "ipkg.conf" | ||
128 | #define ARGS_DEFAULT_DEST NULL | ||
129 | #define ARGS_DEFAULT_FORCE_DEFAULTS 0 | ||
130 | Index: C/ipkg.h.in | ||
131 | =================================================================== | ||
132 | --- C.orig/ipkg.h.in 2005-02-25 15:27:58.000000000 -0600 | ||
133 | +++ /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
134 | @@ -1,60 +0,1 @@ | ||
135 | -/* ipkg.h - the itsy package management system | ||
136 | - | ||
137 | - Carl D. Worth | ||
138 | - | ||
139 | - Copyright (C) 2001 University of Southern California | ||
140 | - | ||
141 | - This program is free software; you can redistribute it and/or | ||
142 | - modify it under the terms of the GNU General Public License as | ||
143 | - published by the Free Software Foundation; either version 2, or (at | ||
144 | - your option) any later version. | ||
145 | - | ||
146 | - This program is distributed in the hope that it will be useful, but | ||
147 | - WITHOUT ANY WARRANTY; without even the implied warranty of | ||
148 | - MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU | ||
149 | - General Public License for more details. | ||
150 | -*/ | ||
151 | - | ||
152 | -#ifndef IPKG_H | ||
153 | -#define IPKG_H | ||
154 | - | ||
155 | -#ifdef HAVE_CONFIG_H | ||
156 | -#include "config.h" | ||
157 | -#endif | ||
158 | - | ||
159 | -#if 0 | ||
160 | -#define IPKG_DEBUG_NO_TMP_CLEANUP | ||
161 | -#endif | ||
162 | - | ||
163 | -#include "includes.h" | ||
164 | -#include "ipkg_conf.h" | ||
165 | -#include "ipkg_message.h" | ||
166 | - | ||
167 | -#define IPKG_PKG_EXTENSION ".ipk" | ||
168 | -#define DPKG_PKG_EXTENSION ".deb" | ||
169 | - | ||
170 | -#define IPKG_LEGAL_PKG_NAME_CHARS "abcdefghijklmnopqrstuvwxyz0123456789.+-" | ||
171 | -#define IPKG_PKG_VERSION_SEP_CHAR '_' | ||
172 | - | ||
173 | -#define IPKG_STATE_DIR_PREFIX LIBDIR"/ipkg" | ||
174 | -#define IPKG_LISTS_DIR_SUFFIX "lists" | ||
175 | -#define IPKG_INFO_DIR_SUFFIX "info" | ||
176 | -#define IPKG_STATUS_FILE_SUFFIX "status" | ||
177 | - | ||
178 | -#define IPKG_BACKUP_SUFFIX "-ipkg.backup" | ||
179 | - | ||
180 | -#define IPKG_LIST_DESCRIPTION_LENGTH 128 | ||
181 | - | ||
182 | -enum ipkg_error { | ||
183 | - IPKG_SUCCESS = 0, | ||
184 | - IPKG_PKG_DEPS_UNSATISFIED, | ||
185 | - IPKG_PKG_IS_ESSENTIAL, | ||
186 | - IPKG_PKG_HAS_DEPENDENTS, | ||
187 | - IPKG_PKG_HAS_NO_CANDIDATE | ||
188 | -}; | ||
189 | -typedef enum ipkg_error ipkg_error_t; | ||
190 | - | ||
191 | -extern int ipkg_state_changed; | ||
192 | - | ||
193 | -#endif | ||
diff --git a/openembedded/packages/ipkg/ipkg-0.99.147/libdir.patch b/openembedded/packages/ipkg/ipkg-0.99.147/libdir.patch deleted file mode 100644 index 38f0b4d286..0000000000 --- a/openembedded/packages/ipkg/ipkg-0.99.147/libdir.patch +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | --- C/ipkg.h.in.old 2005-04-02 17:11:02.762413624 +0100 | ||
2 | +++ C/ipkg.h.in 2005-04-02 17:11:06.314873568 +0100 | ||
3 | @@ -36,7 +36,7 @@ | ||
4 | #define IPKG_LEGAL_PKG_NAME_CHARS "abcdefghijklmnopqrstuvwxyz0123456789.+-" | ||
5 | #define IPKG_PKG_VERSION_SEP_CHAR '_' | ||
6 | |||
7 | -#define IPKG_STATE_DIR_PREFIX LIBDIR"/ipkg" | ||
8 | +#define IPKG_STATE_DIR_PREFIX "/usr/lib/ipkg" | ||
9 | #define IPKG_LISTS_DIR_SUFFIX "lists" | ||
10 | #define IPKG_INFO_DIR_SUFFIX "info" | ||
11 | #define IPKG_STATUS_FILE_SUFFIX "status" | ||
diff --git a/openembedded/packages/ipkg/ipkg-0.99.148/libdir.patch b/openembedded/packages/ipkg/ipkg-0.99.148/libdir.patch deleted file mode 100644 index 38f0b4d286..0000000000 --- a/openembedded/packages/ipkg/ipkg-0.99.148/libdir.patch +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | --- C/ipkg.h.in.old 2005-04-02 17:11:02.762413624 +0100 | ||
2 | +++ C/ipkg.h.in 2005-04-02 17:11:06.314873568 +0100 | ||
3 | @@ -36,7 +36,7 @@ | ||
4 | #define IPKG_LEGAL_PKG_NAME_CHARS "abcdefghijklmnopqrstuvwxyz0123456789.+-" | ||
5 | #define IPKG_PKG_VERSION_SEP_CHAR '_' | ||
6 | |||
7 | -#define IPKG_STATE_DIR_PREFIX LIBDIR"/ipkg" | ||
8 | +#define IPKG_STATE_DIR_PREFIX "/usr/lib/ipkg" | ||
9 | #define IPKG_LISTS_DIR_SUFFIX "lists" | ||
10 | #define IPKG_INFO_DIR_SUFFIX "info" | ||
11 | #define IPKG_STATUS_FILE_SUFFIX "status" | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.129.bb b/openembedded/packages/ipkg/ipkg-native_0.99.129.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.129.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.130.bb b/openembedded/packages/ipkg/ipkg-native_0.99.130.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.130.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.135.bb b/openembedded/packages/ipkg/ipkg-native_0.99.135.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.135.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.138.bb b/openembedded/packages/ipkg/ipkg-native_0.99.138.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.138.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.140.bb b/openembedded/packages/ipkg/ipkg-native_0.99.140.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.140.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.144.bb b/openembedded/packages/ipkg/ipkg-native_0.99.144.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.144.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.146.bb b/openembedded/packages/ipkg/ipkg-native_0.99.146.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.146.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.147.bb b/openembedded/packages/ipkg/ipkg-native_0.99.147.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.147.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.148.bb b/openembedded/packages/ipkg/ipkg-native_0.99.148.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.148.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg-native_0.99.151.bb b/openembedded/packages/ipkg/ipkg-native_0.99.151.bb deleted file mode 100644 index d59eab3a61..0000000000 --- a/openembedded/packages/ipkg/ipkg-native_0.99.151.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.129.bb b/openembedded/packages/ipkg/ipkg_0.99.129.bb deleted file mode 100644 index 35d096739b..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.129.bb +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | include ipkg.inc | ||
2 | PR = "r5" | ||
3 | |||
4 | SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')} \ | ||
5 | file://buffer-overflow.patch;patch=1 \ | ||
6 | file://uninclude-replace.patch;patch=1 \ | ||
7 | file://uclibc.patch;patch=1" | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.130.bb b/openembedded/packages/ipkg/ipkg_0.99.130.bb deleted file mode 100644 index 8d646be408..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.130.bb +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | include ipkg.inc | ||
2 | PR = "r5" | ||
3 | |||
4 | SRC_URI += "file://uninclude-replace.patch;patch=1 \ | ||
5 | file://uclibc.patch;patch=1" | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.135.bb b/openembedded/packages/ipkg/ipkg_0.99.135.bb deleted file mode 100644 index 9a05a1ed05..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.135.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | include ipkg.inc | ||
2 | PR = "r2" | ||
3 | SRC_URI += "file://depends.patch;patch=1 \ | ||
4 | file://uninclude-replace.patch;patch=1 \ | ||
5 | file://remove-c99isms.patch;patch=1 \ | ||
6 | file://uclibc.patch;patch=1" | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.138.bb b/openembedded/packages/ipkg/ipkg_0.99.138.bb deleted file mode 100644 index 1898c6656e..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.138.bb +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | include ipkg.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.140.bb b/openembedded/packages/ipkg/ipkg_0.99.140.bb deleted file mode 100644 index 88bf4a5ac1..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.140.bb +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | include ipkg.inc | ||
2 | PR = "r2" | ||
3 | |||
4 | SRC_URI += "file://remove-c99isms.patch;patch=1" | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.144.bb b/openembedded/packages/ipkg/ipkg_0.99.144.bb deleted file mode 100644 index ff3da77a22..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.144.bb +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | include ipkg.inc | ||
2 | PR = "r2" | ||
3 | SRC_URI += "file://paths.patch;patch=1" | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.146.bb b/openembedded/packages/ipkg/ipkg_0.99.146.bb deleted file mode 100644 index 1898c6656e..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.146.bb +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | include ipkg.inc | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.147.bb b/openembedded/packages/ipkg/ipkg_0.99.147.bb deleted file mode 100644 index 778fa86042..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.147.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg.inc | ||
2 | SRC_URI += "file://libdir.patch;patch=1" | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.148.bb b/openembedded/packages/ipkg/ipkg_0.99.148.bb deleted file mode 100644 index 778fa86042..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.148.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | include ipkg.inc | ||
2 | SRC_URI += "file://libdir.patch;patch=1" | ||
diff --git a/openembedded/packages/ipkg/ipkg_0.99.151.bb b/openembedded/packages/ipkg/ipkg_0.99.151.bb deleted file mode 100644 index 1898c6656e..0000000000 --- a/openembedded/packages/ipkg/ipkg_0.99.151.bb +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | include ipkg.inc | ||