summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/hostap/hostap-modules_0.3.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/hostap/hostap-modules_0.3.9.bb')
-rw-r--r--openembedded/packages/hostap/hostap-modules_0.3.9.bb53
1 files changed, 6 insertions, 47 deletions
diff --git a/openembedded/packages/hostap/hostap-modules_0.3.9.bb b/openembedded/packages/hostap/hostap-modules_0.3.9.bb
index 940b23863b..508c653230 100644
--- a/openembedded/packages/hostap/hostap-modules_0.3.9.bb
+++ b/openembedded/packages/hostap/hostap-modules_0.3.9.bb
@@ -1,48 +1,7 @@
1DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset" 1include hostap-modules.inc
2SECTION = "kernel/modules" 2PR = "r9"
3PRIORITY = "optional"
4MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5LICENSE = "GPL"
6PROVIDES = "virtual/kernel-hostap hostap-conf"
7PR = "r8"
8 3
9SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \ 4SRC_URI += "file://Makefile.patch;patch=1 \
10 file://hostap_cs.conf \ 5 file://add_event.patch;patch=1 \
11 file://Makefile.patch;patch=1 \ 6 file://hostap-utsname.patch;patch=1 \
12 file://add_event.patch;patch=1 \ 7 file://hostap_cardid.patch;patch=1"
13 file://hostap-utsname.patch;patch=1 \
14 file://hostap_cardid.patch;patch=1"
15SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
16 file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
17SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "
18
19S = "${WORKDIR}/hostap-driver-${PV}"
20
21inherit module
22
23# Hack Alert :D
24ARCH_mipsel = "mips"
25MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
26
27NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
28
29do_install() {
30 install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
31 ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
32 ${D}${sysconfdir}/pcmcia
33 for i in ${NET_MODULES}
34 do
35 install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
36 done
37 install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
38 install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
39 cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
40}
41
42PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
43FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
44FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
45FILES_hostap-modules = "/lib/modules/"
46RDEPENDS_hostap-modules-cs = "hostap-modules"
47RDEPENDS_hostap-modules-pci = "hostap-modules"
48RPROVIDES_hostap-modules-cs = "hostap-conf"