diff options
Diffstat (limited to 'openembedded/packages/fontconfig')
5 files changed, 97 insertions, 0 deletions
diff --git a/openembedded/packages/fontconfig/files/local.conf b/openembedded/packages/fontconfig/files/local.conf new file mode 100644 index 0000000000..ddd7cf9d03 --- /dev/null +++ b/openembedded/packages/fontconfig/files/local.conf | |||
@@ -0,0 +1,12 @@ | |||
1 | <?xml version="1.0"?> | ||
2 | <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> | ||
3 | <!-- /etc/fonts/local.conf file for local customizations --> | ||
4 | <fontconfig> | ||
5 | <!-- Enable sub-pixel rendering --> | ||
6 | <match target="font"> | ||
7 | <test qual="all" name="rgba"> | ||
8 | <const>unknown</const> | ||
9 | </test> | ||
10 | <edit name="rgba" mode="assign"><const>rgb</const></edit> | ||
11 | </match> | ||
12 | </fontconfig> | ||
diff --git a/openembedded/packages/fontconfig/fontconfig-2.2.95/fc-glyphname.patch b/openembedded/packages/fontconfig/fontconfig-2.2.95/fc-glyphname.patch new file mode 100644 index 0000000000..1afd9324ff --- /dev/null +++ b/openembedded/packages/fontconfig/fontconfig-2.2.95/fc-glyphname.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | --- fontconfig/fc-glyphname/Makefile.am~ 2004-04-14 17:06:35.000000000 +0100 | ||
2 | +++ fontconfig/fc-glyphname/Makefile.am 2004-05-15 11:41:35.000000000 +0100 | ||
3 | @@ -27,6 +27,7 @@ | ||
4 | TMPL=fcglyphname.tmpl.h | ||
5 | STMPL=${top_srcdir}/fc-glyphname/${TMPL} | ||
6 | TARG=fcglyphname.h | ||
7 | +FC_GLYPHNAME=./fc-glyphname | ||
8 | |||
9 | noinst_PROGRAMS=fc-glyphname | ||
10 | |||
11 | @@ -41,7 +42,7 @@ | ||
12 | |||
13 | $(TARG): $(STMPL) fc-glyphname $(SGLYPHNAME) | ||
14 | rm -f $(TARG) | ||
15 | - ./fc-glyphname $(SGLYPHNAME) < $(STMPL) > $(TARG) | ||
16 | + $(FC_GLYPHNAME) $(SGLYPHNAME) < $(STMPL) > $(TARG) | ||
17 | |||
18 | CLEANFILES=$(TARG) | ||
19 | |||
diff --git a/openembedded/packages/fontconfig/fontconfig-2.2.95/fc-lang.patch b/openembedded/packages/fontconfig/fontconfig-2.2.95/fc-lang.patch new file mode 100644 index 0000000000..d08242a377 --- /dev/null +++ b/openembedded/packages/fontconfig/fontconfig-2.2.95/fc-lang.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | --- fontconfig/fc-lang/Makefile.am~ 2004-04-14 17:06:36.000000000 +0100 | ||
2 | +++ fontconfig/fc-lang/Makefile.am 2004-05-15 11:22:44.000000000 +0100 | ||
3 | @@ -27,6 +27,7 @@ | ||
4 | TMPL=fclang.tmpl.h | ||
5 | STMPL=${top_srcdir}/fc-lang/fclang.tmpl.h | ||
6 | TARG=fclang.h | ||
7 | +FC_LANG=./fc-lang | ||
8 | |||
9 | noinst_PROGRAMS=fc-lang | ||
10 | |||
11 | @@ -40,6 +41,6 @@ | ||
12 | |||
13 | $(TARG):$(ORTH) fc-lang $(STMPL) | ||
14 | rm -f $(TARG) | ||
15 | - ./fc-lang -d ${srcdir} $(ORTH) < $(STMPL) > $(TARG) | ||
16 | + $(FC_LANG) -d ${srcdir} $(ORTH) < $(STMPL) > $(TARG) | ||
17 | |||
18 | CLEANFILES=$(TARG) | ||
diff --git a/openembedded/packages/fontconfig/fontconfig-native_2.2.95.bb b/openembedded/packages/fontconfig/fontconfig-native_2.2.95.bb new file mode 100644 index 0000000000..bc988e0ee2 --- /dev/null +++ b/openembedded/packages/fontconfig/fontconfig-native_2.2.95.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | SECTION = "base" | ||
2 | LICENSE = "BSD" | ||
3 | include fontconfig_${PV}.bb | ||
4 | inherit native | ||
5 | DEPENDS = "freetype-native expat-native zlib-native" | ||
6 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/fontconfig-${PV}" | ||
7 | |||
8 | EXTRA_OEMAKE = "" | ||
9 | |||
10 | do_stage () { | ||
11 | oe_runmake install | ||
12 | install fc-lang/fc-lang ${STAGING_BINDIR} | ||
13 | install fc-glyphname/fc-glyphname ${STAGING_BINDIR} | ||
14 | } | ||
diff --git a/openembedded/packages/fontconfig/fontconfig_2.2.95.bb b/openembedded/packages/fontconfig/fontconfig_2.2.95.bb new file mode 100644 index 0000000000..6989b7a053 --- /dev/null +++ b/openembedded/packages/fontconfig/fontconfig_2.2.95.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SECTION = "libs" | ||
2 | LICENSE = "BSD" | ||
3 | DESCRIPTION = "A library for configuring and customizing font access." | ||
4 | DEPENDS = "expat freetype freetype-native zlib fontconfig-native" | ||
5 | |||
6 | SRC_URI = "http://pdx.freedesktop.org/fontconfig/release/fontconfig-${PV}.tar.gz \ | ||
7 | file://fc-glyphname.patch;patch=1 \ | ||
8 | file://fc-lang.patch;patch=1 \ | ||
9 | file://local.conf" | ||
10 | PR = "r1" | ||
11 | |||
12 | PACKAGES =+ "fontconfig-utils " | ||
13 | FILES_fontconfig-utils = "${bindir}/*" | ||
14 | |||
15 | S = "${WORKDIR}/fontconfig-${PV}" | ||
16 | |||
17 | inherit autotools pkgconfig | ||
18 | |||
19 | export HASDOCBOOK="no" | ||
20 | |||
21 | EXTRA_OECONF = " --disable-docs " | ||
22 | EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname" | ||
23 | |||
24 | do_stage () { | ||
25 | oe_libinstall -so -a -C src libfontconfig ${STAGING_LIBDIR} | ||
26 | install -d ${STAGING_INCDIR}/fontconfig | ||
27 | for i in ${S}/fontconfig/*.h; do install -m 0644 $i ${STAGING_INCDIR}/fontconfig/; done | ||
28 | } | ||
29 | |||
30 | do_install () { | ||
31 | autotools_do_install | ||
32 | install -m 0644 ${WORKDIR}/local.conf ${D}${sysconfdir}/fonts/local.conf | ||
33 | } | ||
34 | |||