summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/contacts/contacts_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/contacts/contacts_0.1.bb')
-rwxr-xr-xopenembedded/packages/contacts/contacts_0.1.bb21
1 files changed, 7 insertions, 14 deletions
diff --git a/openembedded/packages/contacts/contacts_0.1.bb b/openembedded/packages/contacts/contacts_0.1.bb
index f2b81cbd8a..cf025259f2 100755
--- a/openembedded/packages/contacts/contacts_0.1.bb
+++ b/openembedded/packages/contacts/contacts_0.1.bb
@@ -3,29 +3,22 @@ SECTION = "x11"
3DEPENDS = "glib-2.0 gtk+ libglade eds-dbus" 3DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
4MAINTAINER = "Chris Lord <chris@openedhand.com>" 4MAINTAINER = "Chris Lord <chris@openedhand.com>"
5DESCRIPTION = "Contacts is an address-book application." 5DESCRIPTION = "Contacts is an address-book application."
6PR = "r1"
6 7
7SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \ 8SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \
8 file://stock_contact.png \ 9 file://stock_contact.png \
9 file://stock_person.png \ 10 file://stock_person.png"
10 file://index.theme"
11 11
12inherit autotools pkgconfig 12inherit autotools pkgconfig
13 13
14S = "${WORKDIR}/release-0.1" 14S = "${WORKDIR}/release-0.1"
15 15
16do_install_append () { 16do_install_append () {
17 install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net 17 install -d ${D}/${datadir}/pixmaps
18 install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic 18 install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/pixmaps
19 19 install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/pixmaps
20 install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
21 install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
22 install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
23} 20}
24 21
25FILES_${PN} += "${datadir}/icons/hicolor/48x48/stock/*/*.png \ 22FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
26 ${datadir}/icons/hicolor/index.theme" 23 ${datadir}/pixmaps/stock_person.png"
27
28pkg_postinst_${PN} () {
29 gtk-update-icon-cache /usr/share/icons/hicolor
30}
31 24