summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/avahi/avahi_0.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/avahi/avahi_0.6.3.bb')
-rw-r--r--openembedded/packages/avahi/avahi_0.6.3.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/openembedded/packages/avahi/avahi_0.6.3.bb b/openembedded/packages/avahi/avahi_0.6.3.bb
new file mode 100644
index 0000000000..fbd7208d1d
--- /dev/null
+++ b/openembedded/packages/avahi/avahi_0.6.3.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
2HOMEPAGE = "http://avahi.org"
3LICENSE= "GPL"
4DEPENDS = "expat libdaemon dbus-0.60"
5RRECOMMENDS = "libnss-mdns"
6SECTION = "net"
7PRIORITY = "optional"
8PR = "r0"
9
10SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
11
12PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
13
14FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
15FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
16FILES_avahi-daemon = "${sbindir}/avahi-daemon \
17 ${sysconfdir}/avahi/avahi-daemon.conf \
18 ${sysconfdir}/avahi/services \
19 ${sysconfdir}/dbus-1 \
20 ${sysconfdir}/init.d/avahi-daemon \
21 ${datadir}/avahi/introspection/*.introspect \
22 ${datadir}/avahi/avahi-service.dtd \
23 ${datadir}/avahi/service-types"
24FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
25FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
26 ${sysconfdir}/avahi/avahi-dnsconfd.action \
27 ${sysconfdir}/init.d/avahi-dnsconfd"
28FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
29FILES_avahi-utils = "${bindir}/avahi-*"
30
31CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
32
33EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
34inherit autotools
35inherit update-rc.d
36
37INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
38INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
39INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
40INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
41INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
42
43pkg_postinst_avahi-daemon () {
44 grep avahi /etc/group || addgroup avahi
45 grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
46 /etc/init.d/dbus-1 force-reload
47}
48
49pkg_postrm_avahi-daemon () {
50 deluser avahi || true
51 delgroup avahi || true
52}