summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/avahi/avahi_0.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/avahi/avahi_0.5.2.bb')
-rw-r--r--openembedded/packages/avahi/avahi_0.5.2.bb53
1 files changed, 0 insertions, 53 deletions
diff --git a/openembedded/packages/avahi/avahi_0.5.2.bb b/openembedded/packages/avahi/avahi_0.5.2.bb
deleted file mode 100644
index e4291db2c2..0000000000
--- a/openembedded/packages/avahi/avahi_0.5.2.bb
+++ /dev/null
@@ -1,53 +0,0 @@
1DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
2HOMEPAGE = "http://www.freedesktop.org/Software/Avahi"
3LICENSE= "GPL"
4DEPENDS = "expat libdaemon dbus-0.50"
5RRECOMMENDS = "libnss-mdns"
6SECTION = "net"
7PRIORITY = "optional"
8PR = "r0"
9
10SRC_URI = "http://www.freedesktop.org/~lennart/avahi-${PV}.tar.gz \
11 file://alignment-fix.patch;patch=1"
12
13PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc"
14
15FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
16FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
17FILES_avahi-daemon = "${sbindir}/avahi-daemon \
18 ${sysconfdir}/avahi/avahi-daemon.conf \
19 ${sysconfdir}/avahi/services \
20 ${sysconfdir}/dbus-1 \
21 ${sysconfdir}/init.d/avahi-daemon \
22 ${datadir}/avahi/introspection/*.introspect \
23 ${datadir}/avahi/avahi-service.dtd \
24 ${datadir}/avahi/service-types"
25FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
26FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
27 ${sysconfdir}/avahi/avahi-dnsconfd.action \
28 ${sysconfdir}/init.d/avahi-dnsconfd"
29FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
30
31CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
32
33EXTRA_OECONF = "--with-distro=debian --disable-mono --disable-mono-docs --disable-gtk --disable-qt3 --disable-qt4 --disable-python"
34inherit autotools
35inherit update-rc.d
36
37INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
38INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
39INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
40INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
41INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
42
43pkg_postinst_avahi-daemon () {
44 grep avahi /etc/group || addgroup avahi
45 grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
46 /etc/init.d/dbus-1 force-reload
47}
48
49pkg_postrm_avahi-daemon () {
50 deluser avahi || true
51 delgroup avahi || true
52}
53