diff options
Diffstat (limited to 'meta/recipes-support/vte/vte_0.50.1.bb')
-rw-r--r-- | meta/recipes-support/vte/vte_0.50.1.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-support/vte/vte_0.50.1.bb b/meta/recipes-support/vte/vte_0.50.1.bb new file mode 100644 index 0000000000..1c77c7dcee --- /dev/null +++ b/meta/recipes-support/vte/vte_0.50.1.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | SUMMARY = "Virtual terminal emulator GTK+ widget library" | ||
2 | BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte" | ||
3 | LICENSE = "LGPLv2.1+" | ||
4 | DEPENDS = "glib-2.0 gtk+3 libpcre2 intltool-native libxml2-native gperf-native" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | ||
7 | |||
8 | inherit gnomebase gtk-doc distro_features_check upstream-version-is-even gobject-introspection | ||
9 | |||
10 | # vapigen.m4 is required when vala is not present (but the one from vala should be used normally) | ||
11 | SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch \ | ||
12 | ${@bb.utils.contains('PACKAGECONFIG', 'vala', '', 'file://0001-Add-m4-vapigen.m4.patch', d) } \ | ||
13 | " | ||
14 | SRC_URI[archive.md5sum] = "a6f8fec3787e3cb72b3b31a8be6751a4" | ||
15 | SRC_URI[archive.sha256sum] = "cf1708e3e573160e1db107014b3ef70888fefe6b668373fed70e8d1cac45a8c2" | ||
16 | |||
17 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" | ||
18 | |||
19 | # Instead of "inherit vala" we do the relevant settings here so we can | ||
20 | # set DEPENDS based on PACKAGECONFIG. | ||
21 | |||
22 | # Our patched version of Vala looks in STAGING_DATADIR for .vapi files | ||
23 | export STAGING_DATADIR | ||
24 | # Upstream Vala >= 0.11 looks in XDG_DATA_DIRS for .vapi files | ||
25 | export XDG_DATA_DIRS = "${STAGING_DATADIR}" | ||
26 | |||
27 | # Help g-ir-scanner find the .so for linking | ||
28 | do_compile_prepend() { | ||
29 | export GIR_EXTRA_LIBS_PATH="${B}/src/.libs" | ||
30 | } | ||
31 | |||
32 | # Package additional files | ||
33 | FILES_${PN}-dev += "${datadir}/vala/vapi/*" | ||
34 | |||
35 | PACKAGECONFIG ??= "gnutls" | ||
36 | PACKAGECONFIG[vala] = "--enable-vala,--disable-vala,vala-native vala" | ||
37 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls" | ||
38 | |||
39 | CFLAGS += "-D_GNU_SOURCE" | ||
40 | |||
41 | EXTRA_OECONF = "--disable-test-application" | ||
42 | |||
43 | # libtool adds "-nostdlib" when g++ is used. This breaks PIE builds. | ||
44 | # Use libtool-cross (which has a hack to prevent that) instead. | ||
45 | EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" | ||
46 | |||
47 | PACKAGES =+ "libvte" | ||
48 | FILES_libvte = "${libdir}/*.so.* ${libdir}/girepository-1.0/*" | ||