summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vte/vte_0.44.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/vte/vte_0.44.2.bb')
-rw-r--r--meta/recipes-support/vte/vte_0.44.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/vte/vte_0.44.2.bb b/meta/recipes-support/vte/vte_0.44.2.bb
new file mode 100644
index 0000000000..a1204a3c3b
--- /dev/null
+++ b/meta/recipes-support/vte/vte_0.44.2.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Virtual terminal emulator GTK+ widget library"
2BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
3LICENSE = "LGPLv2.1+"
4DEPENDS = "glib-2.0 gtk+3 intltool-native"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8inherit gnomebase gtk-doc distro_features_check upstream-version-is-even vala gobject-introspection
9
10SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch"
11SRC_URI[archive.md5sum] = "eca8f8a9d9f9bb8e9d592d0acfeec015"
12SRC_URI[archive.sha256sum] = "a1ea594814bb136a3a9a6c7656b46240571f6a198825c1111007fe99194b0949"
13
14ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
15
16PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
17
18CFLAGS += "-D_GNU_SOURCE"
19
20# Enable vala only if gobject-introspection is enabled
21EXTRA_OECONF = "--enable-vala=auto --disable-test-application"
22
23# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds.
24# Use libtool-cross (which has a hack to prevent that) instead.
25EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
26
27PACKAGES =+ "libvte"
28FILES_libvte = "${libdir}/*.so.*"