summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vim/vim_8.1.1017.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/vim/vim_8.1.1017.bb')
-rw-r--r--meta/recipes-support/vim/vim_8.1.1017.bb129
1 files changed, 129 insertions, 0 deletions
diff --git a/meta/recipes-support/vim/vim_8.1.1017.bb b/meta/recipes-support/vim/vim_8.1.1017.bb
new file mode 100644
index 0000000000..7627d2844b
--- /dev/null
+++ b/meta/recipes-support/vim/vim_8.1.1017.bb
@@ -0,0 +1,129 @@
1SUMMARY = "Vi IMproved - enhanced vi editor"
2SECTION = "console/utils"
3
4PROVIDES = "xxd"
5DEPENDS = "ncurses gettext-native"
6# vimdiff doesn't like busybox diff
7RSUGGESTS_${PN} = "diffutils"
8LICENSE = "vim"
9LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;endline=287;md5=f1f82b42360005c70b8c19b0ef493f72"
10
11SRC_URI = "git://github.com/vim/vim.git \
12 file://disable_acl_header_check.patch;patchdir=.. \
13 file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \
14 file://0001-src-Makefile-improve-reproducibility.patch;patchdir=.. \
15"
16SRCREV = "493fbe4abee660d30b4f2aef87b754b0a720213c"
17
18S = "${WORKDIR}/git/src"
19
20VIMDIR = "vim${@d.getVar('PV').split('.')[0]}${@d.getVar('PV').split('.')[1]}"
21
22inherit autotools-brokensep update-alternatives
23
24CLEANBROKEN = "1"
25
26# vim configure.in contains functions which got 'dropped' by autotools.bbclass
27do_configure () {
28 rm -f auto/*
29 touch auto/config.mk
30 aclocal
31 autoconf
32 oe_runconf
33 touch auto/configure
34 touch auto/config.mk auto/config.h
35}
36
37#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny
38PACKAGECONFIG ??= ""
39PACKAGECONFIG += " \
40 ${@bb.utils.filter('DISTRO_FEATURES', 'acl selinux', d)} \
41 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtkgui', '', d)} \
42"
43PACKAGECONFIG_class-native = ""
44
45PACKAGECONFIG[gtkgui] = "--enable-gui=gtk2,--enable-gui=no,gtk+,"
46PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
47PACKAGECONFIG[x11] = "--with-x,--without-x,xt,"
48PACKAGECONFIG[tiny] = "--with-features=tiny,--with-features=big,,"
49PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,"
50PACKAGECONFIG[elfutils] = "--enable-elf-check,,elfutils,"
51
52EXTRA_OECONF = " \
53 --disable-gpm \
54 --disable-gtktest \
55 --disable-xim \
56 --disable-netbeans \
57 --with-tlib=ncurses \
58 ac_cv_small_wchar_t=no \
59 vim_cv_getcwd_broken=no \
60 vim_cv_memmove_handles_overlap=yes \
61 vim_cv_stat_ignores_slash=no \
62 vim_cv_terminfo=yes \
63 vim_cv_tgetent=non-zero \
64 vim_cv_toupper_broken=no \
65 vim_cv_tty_group=world \
66 STRIP=/bin/true \
67"
68
69do_install() {
70 autotools_do_install
71
72 # Work around file-rdeps picking up csh, awk, perl or python as a dep
73 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/vim132
74 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/mve.awk
75 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/*.pl
76 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/*.py
77
78 # Install example vimrc from runtime files
79 install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc
80
81 # we use --with-features=big as default
82 mv ${D}${bindir}/${BPN} ${D}${bindir}/${BPN}.${BPN}
83
84 if ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'true', 'false', d)}; then
85 # The mouse being autoenabled is just annoying in xfce4-terminal (mouse
86 # drag make vim go into visual mode and there is no right click menu),
87 # delete the block.
88 sed -i '/the mouse works just fine/,+4d' ${D}/${datadir}/${BPN}/vimrc
89 fi
90}
91
92PARALLEL_MAKEINST = ""
93
94PACKAGES =+ "${PN}-common ${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-tools"
95FILES_${PN}-syntax = "${datadir}/${BPN}/${VIMDIR}/syntax"
96FILES_${PN}-help = "${datadir}/${BPN}/${VIMDIR}/doc"
97FILES_${PN}-tutor = "${datadir}/${BPN}/${VIMDIR}/tutor ${bindir}/${BPN}tutor"
98FILES_${PN}-vimrc = "${datadir}/${BPN}/vimrc"
99FILES_${PN}-data = "${datadir}/${BPN}"
100FILES_${PN}-tools = "${datadir}/${BPN}/${VIMDIR}/tools"
101FILES_${PN}-common = " \
102 ${datadir}/${BPN}/${VIMDIR}/*.vim \
103 ${datadir}/${BPN}/${VIMDIR}/autoload \
104 ${datadir}/${BPN}/${VIMDIR}/colors \
105 ${datadir}/${BPN}/${VIMDIR}/compiler \
106 ${datadir}/${BPN}/${VIMDIR}/ftplugin \
107 ${datadir}/${BPN}/${VIMDIR}/indent \
108 ${datadir}/${BPN}/${VIMDIR}/keymap \
109 ${datadir}/${BPN}/${VIMDIR}/lang \
110 ${datadir}/${BPN}/${VIMDIR}/macros \
111 ${datadir}/${BPN}/${VIMDIR}/plugin \
112 ${datadir}/${BPN}/${VIMDIR}/print \
113 ${datadir}/${BPN}/${VIMDIR}/spell \
114 ${datadir}/icons \
115"
116
117RDEPENDS_${BPN} = "ncurses-terminfo-base"
118# Recommend that runtime data is installed along with vim
119RRECOMMENDS_${BPN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
120
121ALTERNATIVE_${PN} = "vi vim xxd"
122ALTERNATIVE_PRIORITY = "100"
123ALTERNATIVE_TARGET = "${bindir}/${BPN}.${BPN}"
124ALTERNATIVE_LINK_NAME[vi] = "${base_bindir}/vi"
125ALTERNATIVE_LINK_NAME[vim] = "${bindir}/vim"
126ALTERNATIVE_TARGET[xxd] = "${bindir}/xxd"
127ALTERNATIVE_LINK_NAME[xxd] = "${bindir}/xxd"
128
129BBCLASSEXTEND = "native"