summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vim/vim_8.1.1017.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/vim/vim_8.1.1017.bb')
-rw-r--r--meta/recipes-support/vim/vim_8.1.1017.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta/recipes-support/vim/vim_8.1.1017.bb b/meta/recipes-support/vim/vim_8.1.1017.bb
index 7627d2844b..4e3e663c54 100644
--- a/meta/recipes-support/vim/vim_8.1.1017.bb
+++ b/meta/recipes-support/vim/vim_8.1.1017.bb
@@ -6,16 +6,16 @@ DEPENDS = "ncurses gettext-native"
6# vimdiff doesn't like busybox diff 6# vimdiff doesn't like busybox diff
7RSUGGESTS_${PN} = "diffutils" 7RSUGGESTS_${PN} = "diffutils"
8LICENSE = "vim" 8LICENSE = "vim"
9LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;endline=287;md5=f1f82b42360005c70b8c19b0ef493f72" 9LIC_FILES_CHKSUM = "file://runtime/doc/uganda.txt;endline=287;md5=f1f82b42360005c70b8c19b0ef493f72"
10 10
11SRC_URI = "git://github.com/vim/vim.git \ 11SRC_URI = "git://github.com/vim/vim.git \
12 file://disable_acl_header_check.patch;patchdir=.. \ 12 file://disable_acl_header_check.patch \
13 file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \ 13 file://vim-add-knob-whether-elf.h-are-checked.patch \
14 file://0001-src-Makefile-improve-reproducibility.patch;patchdir=.. \ 14 file://0001-src-Makefile-improve-reproducibility.patch \
15" 15"
16SRCREV = "493fbe4abee660d30b4f2aef87b754b0a720213c" 16SRCREV = "493fbe4abee660d30b4f2aef87b754b0a720213c"
17 17
18S = "${WORKDIR}/git/src" 18S = "${WORKDIR}/git"
19 19
20VIMDIR = "vim${@d.getVar('PV').split('.')[0]}${@d.getVar('PV').split('.')[1]}" 20VIMDIR = "vim${@d.getVar('PV').split('.')[0]}${@d.getVar('PV').split('.')[1]}"
21 21
@@ -25,13 +25,15 @@ CLEANBROKEN = "1"
25 25
26# vim configure.in contains functions which got 'dropped' by autotools.bbclass 26# vim configure.in contains functions which got 'dropped' by autotools.bbclass
27do_configure () { 27do_configure () {
28 cd src
28 rm -f auto/* 29 rm -f auto/*
29 touch auto/config.mk 30 touch auto/config.mk
30 aclocal 31 aclocal
31 autoconf 32 autoconf
33 cd ..
32 oe_runconf 34 oe_runconf
33 touch auto/configure 35 touch src/auto/configure
34 touch auto/config.mk auto/config.h 36 touch src/auto/config.mk src/auto/config.h
35} 37}
36 38
37#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny 39#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny
@@ -76,7 +78,7 @@ do_install() {
76 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/*.py 78 chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/*.py
77 79
78 # Install example vimrc from runtime files 80 # Install example vimrc from runtime files
79 install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc 81 install -m 0644 runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc
80 82
81 # we use --with-features=big as default 83 # we use --with-features=big as default
82 mv ${D}${bindir}/${BPN} ${D}${bindir}/${BPN}.${BPN} 84 mv ${D}${bindir}/${BPN} ${D}${bindir}/${BPN}.${BPN}