summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/taglib/taglib_1.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/taglib/taglib_1.9.1.bb')
-rw-r--r--meta/recipes-support/taglib/taglib_1.9.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/taglib/taglib_1.9.1.bb b/meta/recipes-support/taglib/taglib_1.9.1.bb
new file mode 100644
index 0000000000..55e345f1cc
--- /dev/null
+++ b/meta/recipes-support/taglib/taglib_1.9.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Library for reading and editing the meta-data of popular audio formats"
2SECTION = "libs/multimedia"
3HOMEPAGE = "http://taglib.github.io/"
4LICENSE = "LGPLv2.1 | MPL-1"
5LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
6 file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
7 file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
8
9DEPENDS = "zlib"
10
11SRC_URI = "http://taglib.github.io/releases/${BP}.tar.gz"
12SRC_URI[md5sum] = "0d35df96822bbd564c5504cb3c2e4d86"
13SRC_URI[sha256sum] = "72d371cd1419a87ae200447a53bff2be219283071e80fd12337928cc967dc71a"
14
15S = "${WORKDIR}/${BP}"
16
17BINCONFIG = "${bindir}/taglib-config"
18
19inherit cmake pkgconfig binconfig-disabled
20
21PACKAGES =+ "${PN}-c"
22FILES_${PN}-c = "${libdir}/libtag_c.so.*"
23
24EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"
25
26do_configure_prepend () {
27 rm -f ${S}/admin/ltmain.sh
28 rm -f ${S}/admin/libtool.m4.in
29 # Don't have a floating dependeny on boost
30 sed -i -e "s/atomic.hpp/atomic-not-exist.hpp/" ${S}/ConfigureChecks.cmake
31}
32