summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/taglib/taglib_1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/taglib/taglib_1.8.bb')
-rw-r--r--meta/recipes-support/taglib/taglib_1.8.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/taglib/taglib_1.8.bb b/meta/recipes-support/taglib/taglib_1.8.bb
new file mode 100644
index 0000000000..c713e438a8
--- /dev/null
+++ b/meta/recipes-support/taglib/taglib_1.8.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
2SECTION = "libs/multimedia"
3HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
4LICENSE = "LGPLv2.1 | MPL-1"
5LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
6 file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
7 file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
8
9PR = "r0"
10# http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz
11SRC_URI = "https://github.com/downloads/taglib/taglib/taglib-1.8.tar.gz \
12 "
13
14SRC_URI[md5sum] = "dcb8bd1b756f2843e18b1fdf3aaeee15"
15SRC_URI[sha256sum] = "66d33481703c90236a0a9d1c38fd81b584ca7109ded049225f5463dcaffc209a"
16
17S = "${WORKDIR}/taglib-${PV}"
18
19inherit cmake pkgconfig binconfig
20
21PACKAGES =+ "${PN}-c"
22FILES_${PN}-c = "${libdir}/libtag_c.so.*"
23
24do_configure_prepend () {
25 rm -f ${S}/admin/ltmain.sh
26 rm -f ${S}/admin/libtool.m4.in
27}
28