summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/taglib/taglib_1.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/taglib/taglib_1.6.3.bb')
-rw-r--r--meta/recipes-support/taglib/taglib_1.6.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/taglib/taglib_1.6.3.bb b/meta/recipes-support/taglib/taglib_1.6.3.bb
new file mode 100644
index 0000000000..014c34886c
--- /dev/null
+++ b/meta/recipes-support/taglib/taglib_1.6.3.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
2SECTION = "libs/multimedia"
3HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
4LICENSE = "LGPLv2.1 | MPLv1.1"
5LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=db979804f025cf55aabec7129cb671ed \
6 file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
7 file://taglib/audioproperties.h;beginline=1;endline=24;md5=39dcdd772f378a0f8c9a41bc929eccce"
8
9PR = "r0"
10
11SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz \
12 file://configuretweak.patch;patch=1 \
13 file://nolibtool.patch;patch=1"
14
15S = "${WORKDIR}/taglib-${PV}"
16
17inherit autotools pkgconfig binconfig
18
19PACKAGES =+ "${PN}-c"
20FILES_${PN}-dbg += "${bindir}/taglib-config"
21FILES_${PN}-c = "${libdir}/libtag_c.so.*"
22
23do_configure_prepend () {
24 rm -f ${S}/admin/ltmain.sh
25 rm -f ${S}/admin/libtool.m4.in
26}
27