summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/taglib/taglib_1.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/taglib/taglib_1.11.1.bb')
-rw-r--r--meta/recipes-support/taglib/taglib_1.11.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-support/taglib/taglib_1.11.1.bb b/meta/recipes-support/taglib/taglib_1.11.1.bb
new file mode 100644
index 0000000000..ee1b5234bb
--- /dev/null
+++ b/meta/recipes-support/taglib/taglib_1.11.1.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Library for reading and editing the meta-data of popular audio formats"
2SECTION = "libs/multimedia"
3HOMEPAGE = "http://taglib.github.io/"
4LICENSE = "LGPLv2.1 | MPL-1"
5LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
6 file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
7 file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
8
9DEPENDS = "zlib"
10
11SRC_URI = "http://taglib.github.io/releases/${BP}.tar.gz"
12SRC_URI[md5sum] = "cee7be0ccfc892fa433d6c837df9522a"
13SRC_URI[sha256sum] = "b6d1a5a610aae6ff39d93de5efd0fdc787aa9e9dc1e7026fa4c961b26563526b"
14
15UPSTREAM_CHECK_URI = "http://github.com/taglib/taglib/releases/"
16
17BINCONFIG = "${bindir}/taglib-config"
18
19inherit cmake pkgconfig binconfig-disabled
20
21PACKAGES =+ "${PN}-c"
22FILES_${PN}-c = "${libdir}/libtag_c.so.*"
23
24EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
25 -DCMAKE_DISABLE_FIND_PACKAGE_Boost=TRUE \
26 -DHAVE_BOOST_BYTESWAP=FALSE \
27 -DCMAKE_CXX_STANDARD=11 \
28 -DCMAKE_CXX_STANDARD_REQUIRED=OFF \
29 -DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')} \
30"
31CXXFLAGS += "-std=c++11"
32
33do_configure_prepend () {
34 rm -f ${S}/admin/ltmain.sh
35 rm -f ${S}/admin/libtool.m4.in
36}
37
38# without -fPIC depending packages failed with many error like:
39# | <...>/ld: error: <...>/usr/lib/libtag.a(modfilebase.cpp.o): requires unsupported dynamic reloc R_ARM_THM_MOVW_ABS_NC; recompile with -fPIC
40CXXFLAGS += "-fPIC"