diff options
Diffstat (limited to 'meta/recipes-support/sqlite/sqlite3_3080403.bb')
-rw-r--r-- | meta/recipes-support/sqlite/sqlite3_3080403.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-support/sqlite/sqlite3_3080403.bb b/meta/recipes-support/sqlite/sqlite3_3080403.bb new file mode 100644 index 0000000000..7793a751c2 --- /dev/null +++ b/meta/recipes-support/sqlite/sqlite3_3080403.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | require sqlite3.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://sqlite3.h;endline=11;md5=65f0a57ca6928710b418c094b3570bb0" | ||
4 | |||
5 | def sqlite_download_version(d): | ||
6 | pvsplit = d.getVar('PV', True).split('.') | ||
7 | return pvsplit[0] + ''.join([part.rjust(2,'0') for part in pvsplit[1:]]) | ||
8 | |||
9 | PE = "2" | ||
10 | SQLITE_PV = "${@sqlite_download_version(d)}" | ||
11 | SRC_URI = "http://www.sqlite.org/2014/sqlite-autoconf-${PV}.tar.gz" | ||
12 | |||
13 | S = "${WORKDIR}/sqlite-autoconf-${SQLITE_PV}" | ||
14 | |||
15 | SRC_URI[md5sum] = "0f5459cde43cb269e5120ecd2c671ced" | ||
16 | SRC_URI[sha256sum] = "e0e995e23a324a5d6ae95d8a836240382a4d7475d09707fc469c8cafcbd48d65" | ||
17 | |||
18 | # Provide column meta-data API | ||
19 | BUILD_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA" | ||
20 | TARGET_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA" | ||
21 | |||