diff options
Diffstat (limited to 'meta/recipes-support/sqlite/sqlite3_3.8.10.2.bb')
-rw-r--r-- | meta/recipes-support/sqlite/sqlite3_3.8.10.2.bb | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-support/sqlite/sqlite3_3.8.10.2.bb b/meta/recipes-support/sqlite/sqlite3_3.8.10.2.bb new file mode 100644 index 0000000000..c72ad50f60 --- /dev/null +++ b/meta/recipes-support/sqlite/sqlite3_3.8.10.2.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | require sqlite3.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://sqlite3.h;endline=11;md5=65f0a57ca6928710b418c094b3570bb0" | ||
4 | |||
5 | def sqlite_download_version(d): | ||
6 | pvsplit = d.getVar('PV', True).split('.') | ||
7 | return pvsplit[0] + ''.join([part.rjust(2,'0') for part in pvsplit[1:]]) | ||
8 | |||
9 | PE = "3" | ||
10 | SQLITE_PV = "${@sqlite_download_version(d)}" | ||
11 | SRC_URI = "http://www.sqlite.org/2015/sqlite-autoconf-${SQLITE_PV}.tar.gz \ | ||
12 | file://0001-using-the-dynamic-library.patch \ | ||
13 | " | ||
14 | |||
15 | SRC_URI[md5sum] = "a18bfc015cd49a1e7a961b7b77bc3b37" | ||
16 | SRC_URI[sha256sum] = "8382e55a4e7d853c93038562ca3dd00307937fccf1c6b65ddd813e503a56d626" | ||
17 | |||
18 | S = "${WORKDIR}/sqlite-autoconf-${SQLITE_PV}" | ||
19 | |||
20 | # Provide column meta-data API | ||
21 | BUILD_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA" | ||
22 | TARGET_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA" | ||
23 | |||