summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/pth/pth_2.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/pth/pth_2.0.7.bb')
-rw-r--r--meta/recipes-support/pth/pth_2.0.7.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-support/pth/pth_2.0.7.bb b/meta/recipes-support/pth/pth_2.0.7.bb
new file mode 100644
index 0000000000..416e788e5d
--- /dev/null
+++ b/meta/recipes-support/pth/pth_2.0.7.bb
@@ -0,0 +1,31 @@
1SUMMARY = "GNU Portable Threads library"
2HOMEPAGE = "http://www.gnu.org/software/pth/"
3SECTION = "libs"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;beginline=12;endline=15;md5=a48af114a80c222cafd37f24370a77b1"
6PR = "r3"
7
8python __anonymous () {
9 import re
10 uc_os = (re.match('.*uclibc*', d.getVar('TARGET_OS', True)) != None)
11 if uc_os:
12 raise bb.parse.SkipPackage("incompatible with uClibc")
13}
14
15SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \
16 file://pth-add-pkgconfig-support.patch"
17
18SRC_URI[md5sum] = "9cb4a25331a4c4db866a31cbe507c793"
19SRC_URI[sha256sum] = "72353660c5a2caafd601b20e12e75d865fd88f6cf1a088b306a3963f0bc77232"
20
21PARALLEL_MAKE=""
22
23BINCONFIG = "${bindir}/pth-config"
24
25inherit autotools binconfig-disabled pkgconfig
26
27do_configure() {
28 ( cd ${S}; gnu-configize )
29 ( cd ${S}; autoconf )
30 oe_runconf
31}