summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
new file mode 100644
index 0000000000..9e62c486ac
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "1e9a84585909b970cc8850d3ea02a7215dcfa5a3"
11PV = "2.4.0+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
14"
15
16S = "${WORKDIR}/git"
17
18FILES_${PN} = "${bindir}/ptest-runner"
19
20EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
21
22do_compile () {
23 oe_runmake
24}
25
26do_install () {
27 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
28}