summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.0.bb
new file mode 100644
index 0000000000..221cf6c287
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "https://github.com/alimon/ptest-runner2"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "8bfdf946e784f4d5757bebee1fbc4b4a3d7a95c4"
11PV = "2.0+git${SRCPV}"
12
13SRC_URI = "git://github.com/alimon/ptest-runner2.git;protocol=https"
14S = "${WORKDIR}/git"
15
16FILES_${PN} = "${bindir}/ptest-runner"
17
18do_compile () {
19 oe_runmake
20}
21
22do_install () {
23 install -D -m 0755 ${WORKDIR}/git/ptest-runner ${D}${bindir}/ptest-runner
24}