summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_1.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_1.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
new file mode 100644
index 0000000000..7443811d8c
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_1.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A simple shell script to run all installed ptests"
2DESCRIPTION = "The ptest-runner package installs a ptest-runner \
3shell script which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "https://wiki.yoctoproject.org/wiki/Ptest"
6SRC_URI += "file://ptest-runner"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
10 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
11
12INHIBIT_DEFAULT_DEPS = "1"
13
14do_install () {
15 mkdir -p ${D}${bindir}
16 install -m 0755 ${WORKDIR}/ptest-runner ${D}${bindir}
17}
18
19do_patch[noexec] = "1"
20do_configure[noexec] = "1"
21do_compile[noexec] = "1"
22do_build[noexec] = "1"