diff options
Diffstat (limited to 'meta/recipes-support/p11-kit/p11-kit_0.23.14.bb')
-rw-r--r-- | meta/recipes-support/p11-kit/p11-kit_0.23.14.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-support/p11-kit/p11-kit_0.23.14.bb b/meta/recipes-support/p11-kit/p11-kit_0.23.14.bb new file mode 100644 index 0000000000..2a8709143b --- /dev/null +++ b/meta/recipes-support/p11-kit/p11-kit_0.23.14.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "Provides a way to load and enumerate PKCS#11 modules" | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50" | ||
4 | |||
5 | inherit autotools gettext pkgconfig gtk-doc | ||
6 | |||
7 | DEPENDS = "libtasn1 libffi" | ||
8 | |||
9 | SRC_URI = "git://github.com/p11-glue/p11-kit \ | ||
10 | file://0001-LINGUAS-drop-the-languages-for-which-upstream-does-n.patch \ | ||
11 | " | ||
12 | SRCREV = "3770793f026e46a000d2d8816d56122598289d5c" | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | AUTOTOOLS_AUXDIR = "${S}/build/litter" | ||
16 | EXTRA_OECONF = "--without-trust-paths" | ||
17 | |||
18 | # This recipe does not use the standard gtk-doc m4 macros, and so the ./configure flags | ||
19 | # that control gtk-doc build are non-standard | ||
20 | EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-doc --enable-doc-html --disable-doc-pdf', \ | ||
21 | '--disable-doc', d)} " | ||
22 | |||
23 | # When building native recipes, disable gtkdoc, as it is not necessary, | ||
24 | # pulls in additional dependencies, and makes build times longer | ||
25 | EXTRA_OECONF_prepend_class-native = "--disable-doc " | ||
26 | EXTRA_OECONF_prepend_class-nativesdk = "--disable-doc " | ||
27 | |||
28 | UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-gtk-doc-html --disable-gtk-doc-pdf --enable-gtk-doc --disable-gtk-doc" | ||
29 | |||
30 | # p11-kit relies on these two being copied from source tree | ||
31 | # instead of being regenerated by gtkdoc-scan, but doesn't setup | ||
32 | # dependencies correctly when there is a parallel build. Let's pre-copy | ||
33 | # them instead. | ||
34 | do_compile_prepend () { | ||
35 | cp ${S}/doc/manual/p11-kit-overrides.txt ${S}/doc/manual/p11-kit-sections.txt ${B}/doc/manual/ | ||
36 | } | ||
37 | |||
38 | FILES_${PN} += " \ | ||
39 | ${libdir}/p11-kit-proxy.so \ | ||
40 | ${libdir}/pkcs11/*.so \ | ||
41 | ${libdir}/pkcs11/*.la" | ||
42 | |||
43 | # PN contains p11-kit-proxy.so, a symlink to a loadable module | ||
44 | INSANE_SKIP_${PN} = "dev-so" | ||