summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ohm/ohm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/ohm/ohm_git.bb')
-rw-r--r--meta/recipes-support/ohm/ohm_git.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-support/ohm/ohm_git.bb b/meta/recipes-support/ohm/ohm_git.bb
new file mode 100644
index 0000000000..2ba78b35ab
--- /dev/null
+++ b/meta/recipes-support/ohm/ohm_git.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Open Hardware Manager"
2HOMEPAGE = "http://freedesktop.org/Software/ohm"
3LICENSE = "LGPL"
4
5DEPENDS = "gtk+ dbus-glib intltool-native hal"
6RDEPENDS_${PN} += "udev hal-info"
7SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git \
8 file://fix_configure.patch;patch=1"
9
10PV = "0.1.2+git-locrev${SRCREV}"
11PR = "r1"
12
13S = "${WORKDIR}/git"
14
15inherit autotools pkgconfig
16
17EXTRA_OECONF = "--with-distro=debian \
18 --without-xauth \
19 --disable-gtk-doc \
20 --disable-docbook-docs"
21
22do_configure_prepend() {
23 touch gtk-doc.make
24}
25
26OE_LT_RPATH_ALLOW=":${libdir}/libohm:"
27OE_LT_RPATH_ALLOW[export]="1"
28
29PACKAGES =+ "libohm ohm-plugin-x11"
30
31FILES_${PN}-dev += "${libdir}/ohm/*.a"
32
33FILES_${PN} = "${sysconfdir} \
34 ${bindir}/* \
35 ${sbindir}/* \
36 ${libdir}/ohm/*.so \
37 "
38
39FILES_libohm = "${libdir}/libohm.so.*"
40FILES_ohm-plugin-x11 = "${libdir}/ohm/libohm_x*.so \
41 ${libdir}/ohm/libohm_idle.so \
42 ${sysconfdir}/ohm/plugins.d/x* \
43 ${sysconfdir}/ohm/plugins.d/idle* \
44 "