summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb')
-rw-r--r--meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb b/meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb
new file mode 100644
index 0000000000..bbce9e9af0
--- /dev/null
+++ b/meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Name Service Switch module for resolving the local hostname"
2DESCRIPTION = "plugin for the GNU Name Service Switch (NSS) functionality of \
3the GNU C Library (glibc) providing host name resolution for the locally \
4configured system hostname as returned by gethostname(2)."
5HOMEPAGE = "http://0pointer.de/lennart/projects/nss-myhostname/"
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
8
9SRC_URI = "http://0pointer.de/lennart/projects/nss-myhostname/nss-myhostname-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "d4ab9ac36c053ab8fb836db1cbd4a48f"
12SRC_URI[sha256sum] = "2ba744ea8d578d1c57c85884e94a3042ee17843a5294434d3a7f6c4d67e7caf2"
13
14inherit autotools distro_features_check
15
16# The systemd has its own copy of nss-myhostname
17CONFLICT_DISTRO_FEATURES = "systemd"
18
19pkg_postinst_${PN} () {
20 sed -e '/^hosts:/s/\s*\<myhostname\>//' \
21 -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 myhostname \3\4\5/' \
22 -i $D${sysconfdir}/nsswitch.conf
23}
24
25pkg_prerm_${PN} () {
26 sed -e '/^hosts:/s/\s*\<myhostname\>//' \
27 -e '/^hosts:/s/\s*myhostname//' \
28 -i $D${sysconfdir}/nsswitch.conf
29}