summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nettle/nettle_3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/nettle/nettle_3.4.bb')
-rw-r--r--meta/recipes-support/nettle/nettle_3.4.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-support/nettle/nettle_3.4.bb b/meta/recipes-support/nettle/nettle_3.4.bb
new file mode 100644
index 0000000000..e88dba3989
--- /dev/null
+++ b/meta/recipes-support/nettle/nettle_3.4.bb
@@ -0,0 +1,51 @@
1SUMMARY = "A low level cryptographic library"
2HOMEPAGE = "http://www.lysator.liu.se/~nisse/nettle/"
3SECTION = "libs"
4LICENSE = "LGPLv3+ | GPLv2+"
5
6LIC_FILES_CHKSUM = "file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
7 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://serpent-decrypt.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e \
9 file://serpent-set-key.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e"
10
11DEPENDS += "gmp"
12
13SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
14 file://Add-target-to-only-build-tests-not-run-them.patch \
15 file://run-ptest \
16 file://check-header-files-of-openssl-only-if-enable_.patch \
17 "
18
19SRC_URI_append_class-target = "\
20 file://dlopen-test.patch \
21 "
22
23SRC_URI[md5sum] = "dc0f13028264992f58e67b4e8915f53d"
24SRC_URI[sha256sum] = "ae7a42df026550b85daca8389b6a60ba6313b0567f374392e54918588a411e94"
25
26UPSTREAM_CHECK_REGEX = "nettle-(?P<pver>\d+(\.\d+)+)\.tar"
27
28inherit autotools ptest
29
30EXTRA_OECONF = "--disable-openssl"
31
32do_configure_prepend() {
33 if [ ! -e ${S}/acinclude.m4 -a -e ${S}/aclocal.m4 ]; then
34 cp ${S}/aclocal.m4 ${S}/acinclude.m4
35 fi
36}
37
38do_compile_ptest() {
39 oe_runmake buildtest
40}
41
42do_install_ptest() {
43 install -d ${D}${PTEST_PATH}/testsuite/
44 install ${S}/testsuite/gold-bug.txt ${D}${PTEST_PATH}/testsuite/
45 install ${S}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
46 # tools can be found in PATH, not in ../tools/
47 sed -i -e 's|../tools/||' ${D}${PTEST_PATH}/testsuite/*-test
48 install ${B}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
49}
50
51BBCLASSEXTEND = "native nativesdk"