summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nettle/nettle_2.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/nettle/nettle_2.7.1.bb')
-rw-r--r--meta/recipes-support/nettle/nettle_2.7.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/nettle/nettle_2.7.1.bb b/meta/recipes-support/nettle/nettle_2.7.1.bb
new file mode 100644
index 0000000000..f53afcc5d4
--- /dev/null
+++ b/meta/recipes-support/nettle/nettle_2.7.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A low level cryptographic library"
2HOMEPAGE = "http://www.lysator.liu.se/~nisse/nettle/"
3SECTION = "libs"
4LICENSE = "LGPLv2.1 & GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
6 file://serpent-decrypt.c;beginline=53;endline=67;md5=bcfd4745d53ca57f82907089898e390d \
7 file://serpent-set-key.c;beginline=56;endline=70;md5=bcfd4745d53ca57f82907089898e390d"
8
9DEPENDS += "gmp"
10
11SRC_URI = "http://www.lysator.liu.se/~nisse/archive/${BP}.tar.gz"
12
13SRC_URI[md5sum] = "003d5147911317931dd453520eb234a5"
14SRC_URI[sha256sum] = "bc71ebd43435537d767799e414fce88e521b7278d48c860651216e1fc6555b40"
15
16EXTRA_OECONF = "--disable-openssl"
17
18do_configure_prepend() {
19 if [ ! -e ${S}/acinclude.m4 -a -e ${S}/aclocal.m4 ]; then
20 cp ${S}/aclocal.m4 ${S}/acinclude.m4
21 fi
22}
23
24inherit autotools
25
26BBCLASSEXTEND = "native nativesdk"