summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/neon/neon_0.30.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/neon/neon_0.30.1.bb')
-rw-r--r--meta/recipes-support/neon/neon_0.30.1.bb27
1 files changed, 19 insertions, 8 deletions
diff --git a/meta/recipes-support/neon/neon_0.30.1.bb b/meta/recipes-support/neon/neon_0.30.1.bb
index 0244314a63..b6cfd5076f 100644
--- a/meta/recipes-support/neon/neon_0.30.1.bb
+++ b/meta/recipes-support/neon/neon_0.30.1.bb
@@ -4,24 +4,35 @@ SECTION = "libs"
4LICENSE = "LGPLv2+" 4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \ 5LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \
6 file://src/ne_utils.h;beginline=1;endline=20;md5=2caca609538eddaa6f6adf120a218037" 6 file://src/ne_utils.h;beginline=1;endline=20;md5=2caca609538eddaa6f6adf120a218037"
7DEPENDS = "zlib libxml2 expat time gnutls libproxy"
8DEPENDS_class-native = "zlib-native libxml2-native expat-native gnutls-native"
9
10BBCLASSEXTEND = "native"
11 7
12SRC_URI = "http://www.webdav.org/${BPN}/${BPN}-${PV}.tar.gz \ 8SRC_URI = "http://www.webdav.org/${BPN}/${BPN}-${PV}.tar.gz \
13 file://pkgconfig.patch \ 9 file://pkgconfig.patch \
14 file://gnutls_4.3_fixup.patch" 10 file://gnutls_4.3_fixup.patch"
11
15SRC_URI[md5sum] = "231adebe5c2f78fded3e3df6e958878e" 12SRC_URI[md5sum] = "231adebe5c2f78fded3e3df6e958878e"
16SRC_URI[sha256sum] = "00c626c0dc18d094ab374dbd9a354915bfe4776433289386ed489c2ec0845cdd" 13SRC_URI[sha256sum] = "00c626c0dc18d094ab374dbd9a354915bfe4776433289386ed489c2ec0845cdd"
17 14
18BINCONFIG = "${bindir}/neon-config"
19
20inherit autotools binconfig-disabled lib_package pkgconfig 15inherit autotools binconfig-disabled lib_package pkgconfig
21 16
22EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared" 17# Enable gnutls or openssl, not both
23EXTRA_OECONF += "--without-gssapi" 18PACKAGECONFIG ?= "expat gnutls libproxy webdav zlib"
19PACKAGECONFIG_class-native = "expat gnutls webdav zlib"
20
21PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat"
22PACKAGECONFIG[gnutls] = "--with-ssl=gnutls,,gnutls"
23PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5"
24PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
25PACKAGECONFIG[libxml2] = "--with-libxml2,--without-libxml2,libxml2"
26PACKAGECONFIG[openssl] = "--with-ssl=openssl,,openssl"
27PACKAGECONFIG[webdav] = "--enable-webdav,--disable-webdav,"
28PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
29
30EXTRA_OECONF += "--enable-shared"
24 31
25do_compile_append() { 32do_compile_append() {
26 oe_runmake -C test 33 oe_runmake -C test
27} 34}
35
36BINCONFIG = "${bindir}/neon-config"
37
38BBCLASSEXTEND = "native"