summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lzop/lzop_1.03.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/lzop/lzop_1.03.bb')
-rw-r--r--meta/recipes-support/lzop/lzop_1.03.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/lzop/lzop_1.03.bb b/meta/recipes-support/lzop/lzop_1.03.bb
new file mode 100644
index 0000000000..abfc81cfb9
--- /dev/null
+++ b/meta/recipes-support/lzop/lzop_1.03.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Real-time file compressor"
2DESCRIPTION = "lzop is a compression utility which is designed to be a companion to gzip. \n\
3It is based on the LZO data compression library and its main advantages over \n\
4gzip are much higher compression and decompression speed at the cost of some \n\
5compression ratio. The lzop compression utility was designed with the goals \n\
6of reliability, speed, portability and with reasonable drop-in compatibility \n\
7to gzip."
8DEPENDS += "lzo"
9
10LICENSE = "GPLv2+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=dfeaf3dc4beef4f5a7bdbc35b197f39e \
12 file://src/lzop.c;beginline=5;endline=21;md5=6797bd3ed0a1a49327b7ebf9366ebd86"
13
14SRC_URI = "http://www.lzop.org/download/${BP}.tar.gz \
15 file://acinclude.m4"
16SRC_URI[md5sum] = "006c5e27fb78cdd14a628fdfa5aa1905"
17SRC_URI[sha256sum] = "c1425b8c77d49f5a679d5a126c90ea6ad99585a55e335a613cae59e909dbb2c9"
18
19inherit autotools
20
21do_configure () {
22 ln -sf ../acinclude.m4 ${S}/acinclude.m4
23 autotools_do_configure
24}
25
26BBCLASSEXTEND += "native nativesdk"