summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lzo/lzo_2.08.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/lzo/lzo_2.08.bb')
-rw-r--r--meta/recipes-support/lzo/lzo_2.08.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-support/lzo/lzo_2.08.bb b/meta/recipes-support/lzo/lzo_2.08.bb
new file mode 100644
index 0000000000..af06e29a6f
--- /dev/null
+++ b/meta/recipes-support/lzo/lzo_2.08.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Lossless data compression library"
2HOMEPAGE = "http://www.oberhumer.com/opensource/lzo/"
3SECTION = "libs"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://src/lzo_init.c;beginline=5;endline=25;md5=a6e25df9a83b24629e847846ccdd8054"
7
8SRC_URI = "http://www.oberhumer.com/opensource/lzo/download/lzo-${PV}.tar.gz \
9 file://0001-Use-memcpy-instead-of-reinventing-it.patch \
10 file://acinclude.m4 \
11 "
12
13SRC_URI[md5sum] = "fcec64c26a0f4f4901468f360029678f"
14SRC_URI[sha256sum] = "ac1b3e4dee46febe9fd28737eb7f5692d3232ef1a01da10444394c3d47536614"
15
16inherit autotools
17
18EXTRA_OECONF = "--enable-shared"
19
20do_configure_prepend () {
21 cp ${WORKDIR}/acinclude.m4 ${S}/
22}
23
24BBCLASSEXTEND = "native nativesdk"